'95 LT1 w/ 700R trans - Hot Rod Forum : Hotrodders Bulletin Board
Hotrodders.com -- Hot Rod Forum



Register FAQ Search Today's Posts Unanswered Posts Auto Escrow Insurance Auto Loans
Hot Rod Forum : Hotrodders Bulletin Board > Tech Help> Engine
User Name
Password
lost password?   |   register now

Reply
 
LinkBack Thread Tools
  #1 (permalink)  
Old 03-14-2002, 05:55 PM
Registered User
 
Join Date: Oct 2001
Location: Covina, CA
Posts: 5
Wiki Edits: 0

Thanks: 0
Thanked 0 Times in 0 Posts
Post '95 LT1 w/ 700R trans

I'm about to drop a stack of money on an LT1 with a 700R attached. It's still in the '95 Camaro that got totaled. The car took a huge front end hit, wrapped the radiator and assorted forward stuff around the front of the motor. It doesn't appear to have damaged the motor, though I don't know if it continued to run after the collision. This Z-28 motor has TPI and distributorless ignition (position sensors on the crank) Since the ignition system, per se, is on the front of the motor, and that end was first into the radiator, should I expect the ighition NOT to work. It doesn't appear to be damaged, but took one hell of a hit. I will try to turn the engine before it is completely removed from the bent Camaro. The salvage yard has already sold much of the interior of the car so all the ignition wiring is gone...I don't expect it to start. I would appreciate any suggestions as to what I should look for in the way of damaged parts that would eliminate this engine/trans as a candidate for my '58 Apache. (ps...is $2500.00 in the ballpark?)

    Advertisement
Reply With Quote Quick reply to this message
Sponsored Links
Advertisement
 
  #2 (permalink)  
Old 03-14-2002, 09:16 PM
Member
 
Join Date: May 2001
Location: Florida
Posts: 109
Wiki Edits: 0

Thanks: 0
Thanked 0 Times in 0 Posts
Post

I can not call a club member dirtbag so you are dave. Dave the parts in the front of that engine are very costly. If I was going to buy this setup I would make the yard promise in writing that the parts would work. If it would not run they would have to make it good. That is to much money to take a chance.It could cost you 1000.00 dollars in parts if they are broke. Also look at the bellhouseing on the trans for cracks. ROY
Reply With Quote Quick reply to this message
  #3 (permalink)  
Old 03-14-2002, 11:51 PM
Registered User
 
Join Date: Oct 2001
Location: Covina, CA
Posts: 5
Wiki Edits: 0

Thanks: 0
Thanked 0 Times in 0 Posts
Post

Thanks Roy...that's what I needed to know. If the yard won't guarantee the electrics, the deal is off. I will check that bellhousing carefully...I recall now that the Blazer running gear thats in the '58 now had a broken case on the TH350. I didn't worry too much about that at the time because I had an empty case in my garage. Just swapped the innards. However, in this case, I don't have a bare 700R4. I did notice the rear mount was sheared. Lord only knows what I'm gonna find. I'd better be there when they torch the frame away from the engine to see that they dont cook the computer.
Oh yeah, go ahead and call me "Dirtbag". I earned the moniker the hard way...changing the packing in a firepump. You get about six clicks past filty just getting in position.
Reply With Quote Quick reply to this message
  #4 (permalink)  
Old 04-10-2002, 05:16 AM
New Member
 
Join Date: Jan 2002
Location: WV
Posts: 14
Wiki Edits: 0

Thanks: 0
Thanked 0 Times in 0 Posts
Post

I agree the LT-1s are expensive. The LT-1 is in a class of its own, even though its a TPI setup its not the same as its tuned port predecessors. The LT-1 is way more complicated and expensive than the 3rd gen camaro TPI. I have several buddys with LT-1 camaros..... so believe me when I say expensive.
Reply With Quote Quick reply to this message

Recent Engine posts with photos

Quick Reply
Message:
Options

Register Now

In order to be able to post messages on the Hot Rod Forum : Hotrodders Bulletin Board forums, you must first register.
Please enter your desired user name (usually not your first and last name), your email address and other required details in the form below.
User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.
Password:
Confirm Password:
Email Address
Please enter a valid email address for yourself.
Email Address:

Log-in

Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.




Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools

Posting Rules
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On



All times are GMT -6. The time now is 11:27 PM.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.
Search Engine Optimization by vBSEO 3.6.0 PL2
Copyright Hotrodders.com 1999 - 2012. All Rights Reserved.