!970 Corvette brake problems - Hot Rod Forum : Hotrodders Bulletin Board
Hotrodders.com -- Hot Rod Forum



Register FAQ Search Today's Posts Unanswered Posts Auto Escrow Insurance Auto Loans
Hot Rod Forum : Hotrodders Bulletin Board > Tech Help> General Rodding Tech
User Name
Password
lost password?   |   register now

Reply
 
LinkBack Thread Tools
  #1 (permalink)  
Old 08-01-2012, 12:27 PM
EdS EdS is offline
Registered User
 
Join Date: Jul 2012
Posts: 7
Wiki Edits: 0

Thanks: 0
Thanked 0 Times in 0 Posts
!970 Corvette brake problems

I am the original owner of a 454 1970 vette with manual brakes. After replacing the rotors and new cermanic pads and the pain Emer. brakes hard ware,,,I can't build up pressure. I even replaced the master cyl. Blead the system about 15 times and still no pedal. I think it is the back brakes.
Can air get into a rear caliper and not leak? The pedal only goes to the stop where the front pads work,,,so it must be the backs? What am I doing wrong here......ran a garage for years but never ran into this.
also..LF caliper bleeder won't stop bleeding so I temporarily welded the drain hole until I fix the back problem
thanks

    Advertisement

Last edited by EdS; 08-01-2012 at 12:33 PM. Reason: mispelling
Reply With Quote Quick reply to this message
Sponsored Links
Advertisement
 
  #2 (permalink)  
Old 08-01-2012, 03:08 PM
bigdog7373's Avatar
Of course it's fast
 
Last photo:
Join Date: May 2010
Location: florida
Posts: 2,673
Wiki Edits: 0

Thanks: 13
Thanked 49 Times in 49 Posts
Get new bleeder screws. What are the rear brakes drums or disk? If drums they definitely need rebuild. Also may have a corroded line or broken soft line.
Reply With Quote Quick reply to this message
  #3 (permalink)  
Old 08-01-2012, 03:47 PM
poncho62's Avatar
Out of the Loop Moderator
 
Last wiki edit: Streetbeasts links
Last journal entry: at car show
Last photo:
Join Date: Oct 2003
Location: Hanover, Ontario, Canada
Age: 62
Posts: 16,857
Wiki Edits: 5

Thanks: 20
Thanked 247 Times in 201 Posts
70 Vette has disks all around....I remember doing a late 70s for a friend and had a beck of a time bleeding them...Finally it came around
__________________
Ontario Rodders

Budget RVs
Reply With Quote Quick reply to this message
  #4 (permalink)  
Old 08-01-2012, 03:58 PM
bigdog7373's Avatar
Of course it's fast
 
Last photo:
Join Date: May 2010
Location: florida
Posts: 2,673
Wiki Edits: 0

Thanks: 13
Thanked 49 Times in 49 Posts
Figured they would be disks. Just grab some new screws and keep trying. Also check for leaks. Some cars are just a pain in the ***** for certain repairs.
Reply With Quote Quick reply to this message
  #5 (permalink)  
Old 08-01-2012, 04:15 PM
EdS EdS is offline
Registered User
 
Join Date: Jul 2012
Posts: 7
Wiki Edits: 0

Thanks: 0
Thanked 0 Times in 0 Posts
My 70 vette brakes

Thanks to the Ontario gentlemen for your thoughts. As you said....70 is disc on all 4 and they were switched to SSteel by me in the 70's. The bleeders are brand new form Advanced,,so the seat on the caliper must be buggered up......I can live with that for now. I'm still looking for someone to answer me,,,can air be sucked in on a wheel seal but not leak fluid. The feeling is that the master is leaking by but that's brand new yesterday and yes I bench blead the master. The fluid is not going down when pumped up but I don't trust the pressure or lack of it.
I have dragsters and race cars so I'm not new at this but there's no common sense answer why there's no pressure build up and "not leak fluid"
thanks again for your thoughts but I'm still grounded for now
Reply With Quote Quick reply to this message
  #6 (permalink)  
Old 08-01-2012, 04:52 PM
poncho62's Avatar
Out of the Loop Moderator
 
Last wiki edit: Streetbeasts links
Last journal entry: at car show
Last photo:
Join Date: Oct 2003
Location: Hanover, Ontario, Canada
Age: 62
Posts: 16,857
Wiki Edits: 5

Thanks: 20
Thanked 247 Times in 201 Posts
Cant see air getting into a caliper through the seal and not leak fluid...There is just too much pressure for that to happen. Thing is, there is some air in there that you aren't getting out....I take it you are gravity bleeding it...Might try a vacuum bleeder tool

Could also be a faulty new master cylinder......is it new or a rebuilt?
__________________
Ontario Rodders

Budget RVs
Reply With Quote Quick reply to this message
  #7 (permalink)  
Old 08-01-2012, 06:21 PM
Member
 
Last photo:
Join Date: Apr 2004
Location: Georgia
Posts: 3,578
Wiki Edits: 0

Thanks: 10
Thanked 61 Times in 39 Posts
I feel funny offering you advice since youíre the professional mechanic, not me.
Of all the vettes I have owned 30-35 of them were early C-3ís and it is the only car that I could never get the back brakes to bleed so they worked right by either pump and hold or with a pressure bleeder.
The fronts are not a problem, the only way I have found is gravity on the rears and it is the only car where you can take out the bleeders and fluid will not run out on the rear even if you let set two days.

Fill master, take out the bleeder on the rear wheels and with master full, slowly push peddle till fluid starts to comes out, let master then run down on its own and fill 2-3 times, then as strange as this sounds seal up the right one first and let master run down again, fill and tighten the left one.

This has always been a fail safe way that works for me and the only way I could ever make it right.

I do assume your bleeders are on top?? Just asking.
Reply With Quote Quick reply to this message
  #8 (permalink)  
Old 08-01-2012, 06:49 PM
spacytracy's Avatar
Registered User
 

Last journal entry: New neon sign for the garage
Last photo:
Join Date: Nov 2010
Location: utah
Posts: 89
Wiki Edits: 0

Thanks: 0
Thanked 13 Times in 12 Posts
did you bench bleed the new master cylinder?
Reply With Quote Quick reply to this message
  #9 (permalink)  
Old 08-01-2012, 06:59 PM
tnovot's Avatar
Registered User
 
Join Date: Oct 2008
Location: North Central Illinois
Age: 71
Posts: 137
Wiki Edits: 0

Thanks: 0
Thanked 3 Times in 3 Posts
brakes

Barry knows what he is talking about. Corvettes are a b---- to bleed.
Did you have the MC tilted a little when bench bleeding? If not, the MC may have air. Some of the early Vettes have 2 bleeder screws - an inner AND an outer so check for that too.
You might also try asking the guys at corvetteforum.com. Many of them have had the same problem and you can do a search function or just ask by starting a new thread.
Terry
Reply With Quote Quick reply to this message
  #10 (permalink)  
Old 08-01-2012, 07:18 PM
EdS EdS is offline
Registered User
 
Join Date: Jul 2012
Posts: 7
Wiki Edits: 0

Thanks: 0
Thanked 0 Times in 0 Posts
Vette brakes issue- still

Ok guys,
thanks for all of your input. Some didn't read what I said,but I appreciate your comments just the same. TNOvot..you're right it has inner and outer bleeder but the highest one should do the job....but....I'll do both.
Since the car is on one of my lifts, I'll also drop the front and have the back higher as one local mech. said out here. I tried a vacuum bleeder from my friends at Eastwood.......3 tools later I switched to a helper which pumped the brakes while I had a hose in fluid (about ten times ago)
I'm about to stand the car on its head as one racer suggested.
One racer said pull the fronts off the spindle and hold it as high as the rubber hose would allow and pumps them..well that good,but the problem is in the rear (I think)
thanks again...we've beat this horse to death.if I fix it,I'll let you know
thanks again
ed..........................Corvette forum will try
Reply With Quote Quick reply to this message
  #11 (permalink)  
Old 08-01-2012, 07:31 PM
Registered User
 
Join Date: Oct 2007
Location: Michigan
Posts: 106
Wiki Edits: 0

Thanks: 0
Thanked 0 Times in 0 Posts
Rear calipers have two bleeders each and both must be bled. Fix the front before you screw around with back, so you don't fight two problems. If you are bleeding it correctly check rubber hoses.
Are you sure your problem is with rears? If you feel it must be the rears because the brake peddle is soft then goes hard, does that mean that if problem is with front then the peddel is hard then goes soft?
Reply With Quote Quick reply to this message
  #12 (permalink)  
Old 08-01-2012, 08:19 PM
EdS EdS is offline
Registered User
 
Join Date: Jul 2012
Posts: 7
Wiki Edits: 0

Thanks: 0
Thanked 0 Times in 0 Posts
Same vette issue

Henry,
thanks.
I have good flow, with no air coming out of all calip. But.........back has two bleeders and appear that some are missing,,,,so there might be air in the backs. They were removed from the car to screw with the new pads so they were 100% empty...only bleeding one bleeder on each rear might be the issue..If they're missing,,then I'm screwed but I beat this thing to death. I ordered it in 1969 and still trying to make a car of of it.oh well
thanks
Reply With Quote Quick reply to this message
  #13 (permalink)  
Old 08-01-2012, 08:26 PM
Registered User
 
Last photo:
Join Date: Apr 2009
Location: central Illinois
Age: 64
Posts: 59
Wiki Edits: 0

Thanks: 0
Thanked 0 Times in 0 Posts
When we used Corvette brakes in Trans-Am racing Camaros we generally had to use a rubber hammer to beat the snot out of the rear calipers as part of the bleeding process. The hammering shook loose the little bubbles of air that stayed trapped between the piston and the bore, and who knows where else. I have included hammering on the caliper with a rubber mallet as part of the standard bleeding exercise for disc brake calipers ever since.
Reply With Quote Quick reply to this message
  #14 (permalink)  
Old 08-02-2012, 06:35 AM
67Mustang Al.'s Avatar
Registered User
 
Last photo:
Join Date: Jan 2009
Location: Tasmania, Australia.
Posts: 432
Wiki Edits: 0

Thanks: 2
Thanked 6 Times in 6 Posts
I know nothing about vettes , other than helping a guy bring one from San Francisco to AUS. I have 4 wheel discs on my 67 Coupe. When i pieced the car back together and got to do the brake bleeding , i had no pedal pressure . New master c, new calipers, new lines. I could open fronts and have fluid out, but nothing at rear. I bought a vacuum bleeder, no difference, still no pedal pressure. AFter a week of trouble shooting i tried all suggestions from all forums, no luck.
Last thing i tried was to disconnect the rear brake line at the distribution block and hook up a coupling to connect an air hose to the line. (pressurize the line.) With about 10 psi i Found the problem in a minute. I could not believe it. I could hear air escaping from under the car at the rear. The rubber flex coupling connection to one rear caliper was on backwards(my mistake on reassembly) which meant there was an air gap (skewed seat),between the banjo fitting and caliper fluid in port. Therefore everytime the brake pedal went to the floor it pushed air out, and when the pedal came back up it drew air back into the rear line. (5 min fix)
Pressure bleeding may fix your prob. There was a post about a guy who made a plate to cover the top of the MC with an air line coupling attached to force fluid out each bleed screw. About 1/4 thick with a seal to the top of the MC.
Goodluck. I had a can of gas and a match as last resort.
Al.

Last edited by 67Mustang Al.; 08-02-2012 at 06:43 AM.
Reply With Quote Quick reply to this message
  #15 (permalink)  
Old 08-02-2012, 12:03 PM
EdS EdS is offline
Registered User
 
Join Date: Jul 2012
Posts: 7
Wiki Edits: 0

Thanks: 0
Thanked 0 Times in 0 Posts
Dam brakes

You used a rubber mallet,,I used a body hammer and that didn't do it either...I have read everything there is now on this......so
it'll come about eventually if I live that long
thanks
Reply With Quote Quick reply to this message

Recent General Rodding Tech posts with photos

Quick Reply
Message:
Options

Register Now

In order to be able to post messages on the Hot Rod Forum : Hotrodders Bulletin Board forums, you must first register.
Please enter your desired user name (usually not your first and last name), your email address and other required details in the form below.
User Name:
If you do not want to register, fill this field only and the name will be used as user name for your post.
Password
Please enter a password for your user account. Note that passwords are case-sensitive.
Password:
Confirm Password:
Email Address
Please enter a valid email address for yourself.
Email Address:

Log-in

Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.




Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools

Posting Rules
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On


Similar Threads
Thread Thread Starter Forum Replies Last Post
85' corvette brake keep going out WakBordr7387 Suspension - Brakes - Steering 5 03-29-2006 09:56 PM
C4 Corvette Brake Questions S10xGN Suspension - Brakes - Steering 22 02-09-2006 03:35 PM
1976 Corvette brake problems Palmtrees57chevy Suspension - Brakes - Steering 10 09-27-2005 03:21 AM
68 corvette brake lights wixomdave Electrical 3 06-22-2004 04:59 PM
corvette brake help?? mikeweyman Suspension - Brakes - Steering 2 03-25-2003 07:28 PM


All times are GMT -6. The time now is 12:39 PM.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.
Search Engine Optimization by vBSEO 3.6.0 PL2
Copyright Hotrodders.com 1999 - 2012. All Rights Reserved.