98 blazer shifts hard - Hot Rod Forum : Hotrodders Bulletin Board
Hotrodders.com -- Hot Rod Forum



Register FAQ Search Today's Posts Unanswered Posts Auto Escrow Insurance Auto Loans
Hot Rod Forum : Hotrodders Bulletin Board > Tech Help> Transmission - Rearend
User Name
Password
lost password?   |   register now

Reply
 
LinkBack Thread Tools
  #1 (permalink)  
Old 07-03-2005, 03:13 PM
Registered User
 
Join Date: Jul 2005
Location: michigan
Posts: 3
Wiki Edits: 0

Thanks: 0
Thanked 0 Times in 0 Posts
98 blazer shifts hard

Had my trans flushed now it shofts hard any ideas

    Advertisement
Reply With Quote Quick reply to this message
Sponsored Links
Advertisement
 
  #2 (permalink)  
Old 07-03-2005, 05:55 PM
1931 steve's Avatar
Hotrodders.com Moderator
 
Last wiki edit: How to rebuild an engine Last photo:
Join Date: Nov 2004
Location: Michigan
Age: 42
Posts: 1,207
Wiki Edits: 4

Thanks: 0
Thanked 0 Times in 0 Posts
We need more info. What type of trans flush did you get? Was it the drop the pan and replace 5 qst of fluid and filter, or was it the good type that flushes the complete system with 16 qts of fluid? Did you have ANY problems before you had the flush done? If so what? How many miles on the Blazer?

Steve
Reply With Quote Quick reply to this message
  #3 (permalink)  
Old 07-03-2005, 06:24 PM
poncho62's Avatar
Out of the Loop Moderator
 
Last wiki edit: Streetbeasts links
Last journal entry: at car show
Last photo:
Join Date: Oct 2003
Location: Hanover, Ontario, Canada
Age: 62
Posts: 16,857
Wiki Edits: 5

Thanks: 20
Thanked 246 Times in 200 Posts
moving this to tranny forum, where it belongs........
__________________
Ontario Rodders
Reply With Quote Quick reply to this message
  #4 (permalink)  
Old 07-06-2005, 05:40 AM
Registered User
 
Join Date: Jul 2005
Location: michigan
Posts: 3
Wiki Edits: 0

Thanks: 0
Thanked 0 Times in 0 Posts
Quote:
Originally Posted by 1931 steve
We need more info. What type of trans flush did you get? Was it the drop the pan and replace 5 qst of fluid and filter, or was it the good type that flushes the complete system with 16 qts of fluid? Did you have ANY problems before you had the flush done? If so what? How many miles on the Blazer?

Steve


I had a full flush 16 quart ond had no problems before that the tranny is only four month old and still under G.M. warrenty but if theres something I can do to clear it up I would rather do that then put it in the dealer. I also get no error codes. Any ideas?
Reply With Quote Quick reply to this message
  #5 (permalink)  
Old 07-06-2005, 08:03 AM
1931 steve's Avatar
Hotrodders.com Moderator
 
Last wiki edit: How to rebuild an engine Last photo:
Join Date: Nov 2004
Location: Michigan
Age: 42
Posts: 1,207
Wiki Edits: 4

Thanks: 0
Thanked 0 Times in 0 Posts
Take it back to the dealer, I know that dropping your car off at the dealer for at least a week is no good, but if you do anything they(the dealer) can void your warranty. It could be as simple as an connector problem or calibration problem, also could be a hard part. Let the dealer make this call. Ask for a loaner car since you just had it replaced. Also did the dealer do the trans flush for you?
Reply With Quote Quick reply to this message
  #6 (permalink)  
Old 07-06-2005, 05:27 PM
Registered User
 
Join Date: Jul 2005
Location: michigan
Posts: 3
Wiki Edits: 0

Thanks: 0
Thanked 0 Times in 0 Posts
Yes the dealer did the flush. I kind of figured I'd have to take it back to the dealer, but I didn't want to. I use the car to deliver mail and it's been pretty dependable, but lately it's been a real headache. this month it seems like everything is going wrong. I do all my own work on it but I don't know anything about transmissions. This month I've replaced upper and lower ball joints, right hub, upper control arm bushing, rear wiper motor, and today I noticed my rear end pinion shaft seal is leaking. It's been a rough month, but still cheaper to fix it myself rather then buy another. It realy gets abused on the mail route. Anyway thanks for your help.
Reply With Quote Quick reply to this message

Recent Transmission - Rearend posts with photos

Quick Reply
Message:
Options

Register Now

In order to be able to post messages on the Hot Rod Forum : Hotrodders Bulletin Board forums, you must first register.
Please enter your desired user name (usually not your first and last name), your email address and other required details in the form below.
User Name:
If you do not want to register, fill this field only and the name will be used as user name for your post.
Password
Please enter a password for your user account. Note that passwords are case-sensitive.
Password:
Confirm Password:
Email Address
Please enter a valid email address for yourself.
Email Address:

Log-in

Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.




Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools

Posting Rules
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On


Similar Threads
Thread Thread Starter Forum Replies Last Post
98 Blazer Shifting Hard After Long Trip Ghetto Jet Transmission - Rearend 5 06-28-2005 08:41 PM
98 blazer wont start then fires right up jum Engine 2 10-16-2003 03:12 PM
my tranny wont shift hard even with shift kit notmrgoodwrench Transmission - Rearend 4 08-12-2003 06:10 PM
98 Chevy Blazer Overheating sgrobb Engine 1 07-23-2003 03:02 AM
shifts hard mikeh Transmission - Rearend 3 12-04-2002 07:26 PM


All times are GMT -6. The time now is 06:02 AM.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.
Search Engine Optimization by vBSEO 3.6.0 PL2
Copyright Hotrodders.com 1999 - 2012. All Rights Reserved.