99 Yukon trans slips , vibrates then quits working? - Hot Rod Forum : Hotrodders Bulletin Board
Hotrodders.com -- Hot Rod Forum



Register FAQ Search Today's Posts Unanswered Posts Auto Escrow Insurance Auto Loans
Hot Rod Forum : Hotrodders Bulletin Board > Tech Help> Transmission - Rearend
User Name
Password
lost password?   |   register now

Reply
 
LinkBack Thread Tools
  #1 (permalink)  
Old 01-30-2009, 09:56 PM
jesse01's Avatar
mini me
 
Last photo:
Join Date: Feb 2005
Location: titusville, fl.
Age: 31
Posts: 802
Wiki Edits: 0

Thanks: 0
Thanked 0 Times in 0 Posts
99 Yukon trans slips , vibrates then quits working?

have something to do with this problem....

so today a perfect ending to my crummy day. i'm coming back home from droppin someone off at the airport. and my 99 Yukon starts shifting funny and slippin real bad and vibrates when i go to step into it. it always had a lil slip in it, but tonite it was doing it bad. so anyway i keep on truckin and the next thing i know it won't go. so i pull over and do the man thing and get out and look under the truck and check the fluid and all is good, so i get back in it and shut it off thinkin maybe the filter was clogged and the debris would fall back down into the pan.....ya well i'm here typing away so obviuosly that wasn't the case either......

so tomorrow i'm gonna go pull me a tranny and get started on changin it out, which really sux b/c it happened at the worst time EVER!!!! as of the 1st i'm gonna be homeless and no truck yay for me life is GRAND..........so before i go thru all this trouble of changing it i just wanna know if i should be concerned about the torque converter too? or do guys/gals think it's just the tranny that take a poop....

any advice, suggestions, or replies would mean the world to me as of right now and would be GREATLY appreciated..


thanks always,

-J

    Advertisement
Reply With Quote Quick reply to this message
Sponsored Links
Advertisement
 
  #2 (permalink)  
Old 01-30-2009, 10:13 PM
Registered User
 
Join Date: Dec 2004
Location: San Jose Ca
Age: 62
Posts: 472
Wiki Edits: 0

Thanks: 0
Thanked 0 Times in 0 Posts
Trans

All that crap is in the converter and the oil cooler,both need replacing along with flushing the lines.
Reply With Quote Quick reply to this message
  #3 (permalink)  
Old 01-31-2009, 02:05 AM
SSedan64's Avatar
Registered User
 
Last photo:
Join Date: Dec 2007
Location: Macon, GA.
Age: 50
Posts: 6,016
Wiki Edits: 0

Thanks: 0
Thanked 46 Times in 46 Posts
I have to agree with SDLuck.
Any time a trans takes a crap, especially when there's long term slippage, vibrations, then nothing there's going to be clutch material & probably metal shavings anywhere fluid goes thru the trans, converter & cooler.
Save yourself more trouble and get a new converter. Also change the filter, pan gasket and front/input & rear/output trans seal on the trans you're swapping in.
Buy a trans flush kit or a few spray cans of brake cleaner then blast compressed air both directions thru the lines & cooler in the radiator.
When it rains it pours, I'm sure you're needing the truck for the move.
Good luck with the swap.
Reply With Quote Quick reply to this message

Recent Transmission - Rearend posts with photos

Quick Reply
Message:
Options

Register Now

In order to be able to post messages on the Hot Rod Forum : Hotrodders Bulletin Board forums, you must first register.
Please enter your desired user name (usually not your first and last name), your email address and other required details in the form below.
User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.
Password:
Confirm Password:
Email Address
Please enter a valid email address for yourself.
Email Address:

Log-in

Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.




Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools

Posting Rules
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On


Similar Threads
Thread Thread Starter Forum Replies Last Post
4l60e trans slips and shakes the truck cabledawg Transmission - Rearend 1 01-16-2008 06:38 AM
Trans slips out of overdrive under NO LOAD? weirdbeard Transmission - Rearend 10 10-07-2007 12:40 PM
'93 4T60E - Same trans, different prob - Slips in low/reverse after rebuild mjw Transmission - Rearend 15 04-10-2007 09:24 PM
1983 chev trans slips DougMN Transmission - Rearend 19 12-16-2006 09:15 AM


All times are GMT -6. The time now is 05:38 AM.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.
Search Engine Optimization by vBSEO 3.6.0 PL2
Copyright Hotrodders.com 1999 - 2012. All Rights Reserved.