Hot Rod Forum : Hotrodders Bulletin Board

Hot Rod Forum : Hotrodders Bulletin Board (http://www.hotrodders.com/forum/)
-   Engine (http://www.hotrodders.com/forum/engine/)
-   -   Afterfire at high rpm and loss of power (http://www.hotrodders.com/forum/afterfire-high-rpm-loss-power-228324.html)

Stormtrooper 01-13-2013 06:30 AM

Afterfire at high rpm and loss of power
 
Alright I have a 350 Chevy with at th350 behind it. Pretty much stock brides 1406 edelbrock carb.

When accelerating it does fine but when I get about half throttle when I hit a certain point it feels like its bogging down and loses power. Let off before to right before that point and power cones back. If I'm just accelerating or going less than 40 and I punch it it will just bog down but if I punch it past the certain point while on the highway going 65 or so it will Afterfire once real big. Out the exhaust then bog down. Im thinking the after fire is related to the rpms rather than my speed. If I drop it into second from third then gun it will also Afterfire. But at the lower rpms it just bogs. And I think the certain point may be when the secondary's open.

I could be wrong but I think my problem is being way rich at wot. It never backfires out of the carb. Car weighs about 4700 pounds if that matters

RWENUTS 01-13-2013 08:41 AM

What's your timing set up?
How much initial?
How much in the distributor?
Where's your vac advance hooked to. Ported or manifold?

vinniekq2 01-13-2013 09:56 AM

what kind of ignition are you using?


All times are GMT -6. The time now is 03:37 AM.

Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.
Search Engine Optimization by vBSEO 3.6.0 PL2
Copyright Hotrodders.com 1999 - 2012. All Rights Reserved.