Alternator - Hot Rod Forum : Hotrodders Bulletin Board
Hotrodders.com -- Hot Rod Forum



Register FAQ Search Today's Posts Unanswered Posts Auto Escrow Insurance Auto Loans
Hot Rod Forum : Hotrodders Bulletin Board > Tech Help> Hotrodding Basics
User Name
Password
lost password?   |   register now

Reply
 
LinkBack Thread Tools
  #1 (permalink)  
Old 10-21-2012, 09:12 AM
Registered User
 
Join Date: Oct 2012
Posts: 8
Wiki Edits: 0

Thanks: 0
Thanked 0 Times in 0 Posts
Alternator

I have been having problems with the battery not charging by the alternator I've checked both battery and alt both work but I'm run eltric fan and pump and relocated the bat to the trunk I think the alt isn't big enough to compete with the power need of the motor ,fan and pump.

    Advertisement
Reply With Quote Quick reply to this message
Sponsored Links
Advertisement
 
  #2 (permalink)  
Old 10-21-2012, 10:44 AM
Faith - Respect - Trust
 
Last photo:
Join Date: Sep 2012
Location: Ontario
Age: 59
Posts: 3,508
Wiki Edits: 0

Thanks: 192
Thanked 638 Times in 572 Posts
What kind of car? How many amps and volts is your alternator putting out now, not what it's rated at but, putting out? Do you have AC and what other electric options do you have on your car?
Reply With Quote Quick reply to this message
  #3 (permalink)  
Old 10-21-2012, 11:07 AM
Registered User
 
Join Date: Oct 2012
Posts: 8
Wiki Edits: 0

Thanks: 0
Thanked 0 Times in 0 Posts
Alternator

It's a 1978 impala no assories except power steering the volts read about 14 on alternator and it's a stock one haven't checked amps but it charges slowly but it doesn't keep it up if u get what I mean.
Reply With Quote Quick reply to this message
  #4 (permalink)  
Old 10-21-2012, 11:13 AM
poncho62's Avatar
Out of the Loop Moderator
 
Last wiki edit: Streetbeasts links
Last journal entry: at car show
Last photo:
Join Date: Oct 2003
Location: Hanover, Ontario, Canada
Age: 62
Posts: 17,050
Wiki Edits: 5

Thanks: 24
Thanked 343 Times in 265 Posts
Stock, I believe those put out 37 amps.....AC cars had a 63 amp. They also had an external regulator. Are you checking the output at the alternator or the battery?
__________________
Ontario Rodders
Reply With Quote Quick reply to this message
  #5 (permalink)  
Old 10-21-2012, 12:19 PM
Registered User
 
Join Date: Oct 2012
Posts: 8
Wiki Edits: 0

Thanks: 0
Thanked 0 Times in 0 Posts
I've done both I've kinda got it narrowed down to the belt is stretched or I need a bigger amp alt
Reply With Quote Quick reply to this message
  #6 (permalink)  
Old 10-21-2012, 12:30 PM
Faith - Respect - Trust
 
Last photo:
Join Date: Sep 2012
Location: Ontario
Age: 59
Posts: 3,508
Wiki Edits: 0

Thanks: 192
Thanked 638 Times in 572 Posts
Quote:
Originally Posted by hotrodding vet View Post
I've done both I've kinda got it narrowed down to the belt is stretched or I need a bigger amp alt
If the belt is stretched, replace it...If your alternator is stock (70 amp or less) you need a bigger alternator. Check your out put at the battery, longer cables (maybe thinner cables than required) can effect the input to your battery.

If you externally charge the battery (with a plug in charger) and leave it for several days and it loses charge, you either have a bad battery or an electrical short in your vehicle.

Hope this helps
Reply With Quote Quick reply to this message
  #7 (permalink)  
Old 10-21-2012, 12:38 PM
Faith - Respect - Trust
 
Last photo:
Join Date: Sep 2012
Location: Ontario
Age: 59
Posts: 3,508
Wiki Edits: 0

Thanks: 192
Thanked 638 Times in 572 Posts
Quick note...100 amp alternators can be picked up for relatively little expense. Remember, your alternator should put out between 13.5 and 14.5 volts...your regulator will govern that, the amount of amperage is what allows you to run a multitude of accessories. Just like your house, you can have a 20 amp circuit, it's there for you all the time, it just allows you to use more blow dryers, easy bake ovens and electric lawnmowers than a 15 amp circuit.

Hope This Helps
Ray
Reply With Quote Quick reply to this message

Recent Hotrodding Basics posts with photos

Quick Reply
Message:
Options

Register Now

In order to be able to post messages on the Hot Rod Forum : Hotrodders Bulletin Board forums, you must first register.
Please enter your desired user name (usually not your first and last name), your email address and other required details in the form below.
User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.
Password:
Confirm Password:
Email Address
Please enter a valid email address for yourself.
Email Address:

Log-in

Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.




Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools

Posting Rules
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On


Similar Threads
Thread Thread Starter Forum Replies Last Post
alternator oldfart952 Electrical 4 09-14-2010 05:33 PM
What did I do to my alternator? Bill-E-BoB Electrical 3 08-26-2010 02:39 PM
Alternator gazim Electrical 6 05-07-2009 06:13 PM
alternator gm omega69 Electrical 3 04-29-2007 04:12 AM
alternator raymar87 Electrical 0 02-03-2003 05:48 PM


All times are GMT -6. The time now is 02:54 PM.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.
Search Engine Optimization by vBSEO 3.6.0 PL2
Copyright Hotrodders.com 1999 - 2012. All Rights Reserved.