Am I going mad?! - Hot Rod Forum : Hotrodders Bulletin Board
Hotrodders.com -- Hot Rod Forum



Register FAQ Search Today's Posts Unanswered Posts Auto Escrow Insurance Auto Loans
Hot Rod Forum : Hotrodders Bulletin Board > Tech Help> Engine
User Name
Password
lost password?   |   register now

Reply
 
LinkBack Thread Tools
  #1 (permalink)  
Old 03-13-2006, 03:33 PM
Registered User
 

Last journal entry: Better late than never
Last photo:
Join Date: Feb 2006
Location: Palm Beach, FL
Posts: 237
Wiki Edits: 0

Thanks: 0
Thanked 0 Times in 0 Posts
Is this carb setup on backwards?!

OK, I will start out by saying I am probably being VERY dim here but I am about to install the new carb/manifold setup I just purchased onto a 350 SBC and didnt want to make a stupid mistake!

Everything came pre-built and ready to bolt in and go. The issue is that the linkage for connection to my accelerator cable 'appears' to be on the wrong side indicating that all the carbs might need taking off and reversing! The linkage is on the passenger's side with the connection for the cable 'I think' heading to the front of the car instead of the firewall?

Hopefully the photos will illustrate that either a) there is a problem or b) I am stupid. I have circled in red where I assume the throttle cable attaches to the linkage.

Can anyone enlighten a poor soul?!!

Thanks,
Paul
Attached Thumbnails
Click image for larger version

Name:	front.jpg
Views:	57
Size:	55.5 KB
ID:	10758   Click image for larger version

Name:	back.jpg
Views:	59
Size:	48.6 KB
ID:	10759  

Last edited by pcoghlan; 03-13-2006 at 03:40 PM.
Reply With Quote Quick reply to this message
Sponsored Links
Advertisement
 
  #2 (permalink)  
Old 03-13-2006, 03:51 PM
1939beast's Avatar
Wherever you go, there you are
 
Last photo:
Join Date: Feb 2006
Location: western NC
Age: 60
Posts: 47
Wiki Edits: 0

Thanks: 0
Thanked 0 Times in 0 Posts
The throttle cable needs to attach to the linkage on the left of the center carb. The linkage on the right is fo r the 1st and 3rd carbs. the circle you have drawn looks like a sliding joint to adjust when the 1st and 3rd come in.
Reply With Quote Quick reply to this message
  #3 (permalink)  
Old 03-13-2006, 04:02 PM
Registered User
 

Last journal entry: Better late than never
Last photo:
Join Date: Feb 2006
Location: Palm Beach, FL
Posts: 237
Wiki Edits: 0

Thanks: 0
Thanked 0 Times in 0 Posts
thanks 1939, so the answer was b) !

I have had flu for the last few days and am not thinking straight. It is of course now obvious when I look at it!

Thanks,,
Reply With Quote Quick reply to this message

Recent Engine posts with photos

Quick Reply
Message:
Options

Register Now

In order to be able to post messages on the Hot Rod Forum : Hotrodders Bulletin Board forums, you must first register.
Please enter your desired user name (usually not your first and last name), your email address and other required details in the form below.
User Name:
If you do not want to register, fill this field only and the name will be used as user name for your post.
Password
Please enter a password for your user account. Note that passwords are case-sensitive.
Password:
Confirm Password:
Email Address
Please enter a valid email address for yourself.
Email Address:

Log-in

Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.




Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools

Posting Rules
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On


Similar Threads
Thread Thread Starter Forum Replies Last Post
Mad Max Malibu73 Hotrodders' Lounge 10 01-09-2006 05:18 AM
Mad Max Interceptor for sale on ebay? Jon Hotrodders' Lounge 2 09-19-2005 02:02 PM
Mad Cow Bad Rat Hotrodders' Lounge 8 01-09-2004 05:44 AM
Mad Cow and trolls Steve karch Hotrodders' Lounge 31 12-29-2003 12:25 AM
can I get a double-post? Jon Hotrodders' Lounge 9 07-24-2003 07:23 AM


All times are GMT -6. The time now is 10:02 AM.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.
Search Engine Optimization by vBSEO 3.6.0 PL2
Copyright Hotrodders.com 1999 - 2012. All Rights Reserved.