another new member here - Hot Rod Forum : Hotrodders Bulletin Board
Hotrodders.com -- Hot Rod Forum



Register FAQ Search Today's Posts Unanswered Posts Auto Escrow Insurance Auto Loans
Hot Rod Forum : Hotrodders Bulletin Board > Tech Help> Hotrodding Basics
User Name
Password
lost password?   |   register now

Reply
 
LinkBack Thread Tools
  #1 (permalink)  
Old 12-10-2003, 12:22 AM
Grant209's Avatar
Member
 
Join Date: Dec 2003
Location: Modesto, Ca
Age: 31
Posts: 36
Wiki Edits: 0

Thanks: 0
Thanked 0 Times in 0 Posts
another new member here

whats up im new here....i have 74 chevy Nova that i have been working on for almost a year now....it had a staight six in it that had no power at all so pulled it out and slapped a pretty stock 350 in it with an Edelbrock Torker II intake manifold, Hooker Competion Headers, 625 Road Demon Jr. carb i have a crane energizer cam and lifter set that i will be putting in the engine soon 454" lift, 216 duration @.050, i have the crane cam matching valve spings ang retainers for it....its not a big cam but it should work alright.....im having a few problems with idleing and running too rich right now but hopefully i will clear it up soon.....but i have been looking at this board for a day or so and it seems pretty cool....Later
Reply With Quote Quick reply to this message
Sponsored Links
Advertisement
 
  #2 (permalink)  
Old 12-10-2003, 07:54 AM
Tazz
 
Last photo:
Join Date: Jun 2001
Location: amherst,ohio
Age: 65
Posts: 2,049
Wiki Edits: 0

Thanks: 0
Thanked 0 Times in 0 Posts
Another Nova guy, welcome anyway. First off CK this site for help too. www.chevytalk.com/
I believe your car is running rich because of your carb. Do you know how to lean it out a bit?


Todd


Rat Rods Rule!
Reply With Quote Quick reply to this message
  #3 (permalink)  
Old 12-10-2003, 10:56 PM
Grant209's Avatar
Member
 
Join Date: Dec 2003
Location: Modesto, Ca
Age: 31
Posts: 36
Wiki Edits: 0

Thanks: 0
Thanked 0 Times in 0 Posts
Thanks for the welcome....and yeah its running rich cause of the carb but working on fixing it....
Reply With Quote Quick reply to this message

Recent Hotrodding Basics posts with photos

Quick Reply
Message:
Options

Register Now

In order to be able to post messages on the Hot Rod Forum : Hotrodders Bulletin Board forums, you must first register.
Please enter your desired user name (usually not your first and last name), your email address and other required details in the form below.
User Name:
If you do not want to register, fill this field only and the name will be used as user name for your post.
Password
Please enter a password for your user account. Note that passwords are case-sensitive.
Password:
Confirm Password:
Email Address
Please enter a valid email address for yourself.
Email Address:

Log-in

Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.




Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools

Posting Rules
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On



All times are GMT -6. The time now is 02:11 PM.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.
Search Engine Optimization by vBSEO 3.6.0 PL2
Copyright Hotrodders.com 1999 - 2012. All Rights Reserved.