Any turbo gurus out there? - Hot Rod Forum : Hotrodders Bulletin Board
Hotrodders.com -- Hot Rod Forum



Register FAQ Search Today's Posts Unanswered Posts Auto Escrow Insurance Auto Loans
Hot Rod Forum : Hotrodders Bulletin Board > Tech Help> Engine
User Name
Password
lost password?   |   register now

Reply
 
LinkBack Thread Tools
  #1 (permalink)  
Old 03-25-2003, 09:18 PM
rfb92345's Avatar
Member
 
Join Date: Oct 2002
Location: Hesperia, CA
Posts: 112
Wiki Edits: 0

Thanks: 0
Thanked 0 Times in 0 Posts
Unhappy Any turbo gurus out there?

I have an '88 Ford TurboCoupe, T3/T4, ported head and intake, 65mm TB, SDS computer, 3" downpipe, SVO roller cam, 3.55 rear, C4. The car ran good for about 6 mos, running up to 20lbs of boost. I now, all of a sudden, get a strange fluttering noise when I back out of the throttle slightly on boost. It almost sounds like the compressor release. I disable the comp' release, but to no avail. I also disabled the boost control, but to no avail. The noise seem to be coming from the comp' inlet. Could the compressor be surging? If so why now, all of a sudden? Any help will be appreciated.

    Advertisement
Reply With Quote Quick reply to this message
Sponsored Links
Advertisement
 
  #2 (permalink)  
Old 03-26-2003, 04:51 AM
aka Duke of URL
 
Last wiki edit: Finding vacuum leaks Last photo:
Join Date: Oct 2001
Location: Rockville, MD
Posts: 4,821
Wiki Edits: 1

Thanks: 0
Thanked 0 Times in 0 Posts
Arrow

-North American Turbocoupe Organization-

You are more likely to find the answer at the above URL Please let us know what you found...
Reply With Quote Quick reply to this message
  #3 (permalink)  
Old 03-27-2003, 02:38 PM
rfb92345's Avatar
Member
 
Join Date: Oct 2002
Location: Hesperia, CA
Posts: 112
Wiki Edits: 0

Thanks: 0
Thanked 0 Times in 0 Posts
Post

Thanks for the tip. I like the board much better than the one I was on. I will inform you of any progress.
Reply With Quote Quick reply to this message

Recent Engine posts with photos

Quick Reply
Message:
Options

Register Now

In order to be able to post messages on the Hot Rod Forum : Hotrodders Bulletin Board forums, you must first register.
Please enter your desired user name (usually not your first and last name), your email address and other required details in the form below.
User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.
Password:
Confirm Password:
Email Address
Please enter a valid email address for yourself.
Email Address:

Log-in

Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.




Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools

Posting Rules
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On



All times are GMT -6. The time now is 10:47 AM.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.
Search Engine Optimization by vBSEO 3.6.0 PL2
Copyright Hotrodders.com 1999 - 2012. All Rights Reserved.