Hot Rod Forum : Hotrodders Bulletin Board

Hot Rod Forum : Hotrodders Bulletin Board (http://www.hotrodders.com/forum/)
-   Electrical (http://www.hotrodders.com/forum/electrical/)
-   -   Anybody know what this box is for? (http://www.hotrodders.com/forum/anybody-know-what-box-228006.html)

crownver 01-05-2013 09:28 PM

Anybody know what this box is for?
 
2 Attachment(s)
Took the dash out of my 77 Ford F100 shortbox today. Found this electrical component on the drivers side up in by the parking brake release. I have no idea what it does. Doesn't seem to be anyplace to plug it in. This truck has been screwed with a lot over the last 35 years. I know it was a standard 4 speed at one time due to the hole in the hump. Anybody recognize it? Do I need it.

cucumber1949 01-06-2013 06:08 AM

Controller for delay wipers?

carolinacustoms 01-06-2013 06:18 AM

The part number on the box makes it a wiper realy. It is supposed to plug between the switch and wiper motor. Im not sure it is a "delay" or not though.

crownver 01-06-2013 12:56 PM

OK. Thanks guys. So I guess at one time the truck had delay wipers. I wonder if I can hook it back up, if it's any good. Does it take a special motor for delay wipers?

carolinacustoms 01-06-2013 05:40 PM

I'm not so sure it is a wiper delay. It may be though. The part number comes back to a wiper relay. Do you wipers work now? If so plug the relay in line and see if anything changes.

66GMC 01-06-2013 05:52 PM

I worked as a Ford partsman from 1978 to 1992, and agree with what cucumber has told you ... "17C476" was the ford basic number for a wiper delay module. (NAPA and Blue Streak DO call them a "relay" though)

If you go to Bluestreak's Online Catalog and then click on the cross-reference tab. Enter "17C476" into the text-box, and then click on the "contains" selection and press [Search]

The way to tell for sure is by the look of the switch. The "interval wiper" switch had an addition external wire lead on it.

crownver 01-06-2013 07:20 PM

Thanks guys,
The dash is out now, but when the truck was running the wipers worked fine, but only 2 speed, and I think the switch is just a 2 speed. As I said the truck has been screwed with over the years and maybe originally it had delay wipers, but not when I got it. There's nowhere to actually plug this thing in. Wires go directly from the wiper motor to the switch.


All times are GMT -6. The time now is 04:48 AM.

Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.
Search Engine Optimization by vBSEO 3.6.0 PL2
Copyright Hotrodders.com 1999 - 2012. All Rights Reserved.