Hot Rod Forum : Hotrodders Bulletin Board - View Single Post - Anyone have trouble with the kobalt compressor
View Single Post
  #1 (permalink)  
Old 05-13-2006, 03:51 PM
5dogsisenuff 5dogsisenuff is offline
Member
 
Join Date: Apr 2005
Location: ohio
Posts: 104
Wiki Edits: 0

Thanks: 0
Thanked 0 Times in 0 Posts
Anyone have trouble with the kobalt compressor

I bought a 60 gallon 3.5hp compressor from lowes this past september, I had it wired into my garage professionally , I broke it in like the instructions said, and I really havent used it all that much, except for blowin up a few tires because it has been so cold here, anyhow i got to finally use it last week, I wanted to finally sand down my fenders with it, I turned it on and I was standing right by it, and it built up to 60psi, and something popped inside of it, scared the you no what out of me, anyhow, now it wont do nothing, just hums, so I called the # on the compressor for assistance, all I get is a recording to leave my name and # and no one ever calls back, so I called lowes where I got it at, and I had some young girl tell me that I need to bring it in, Ijust laughed, I tried explaining that its hard wired into my garage, she dint understand, so
I got some manager on the phone, thank god he understood, and gave me another # to call, Ive talked to these people like 4 different times , and they keep giving me the run around that they cant find a service tech in my area, this sucks, cause I paid for the extra warranty, im sure its a good company but I just dont know what to do at this point, sorry for the book

chris
Reply With Quote