Hot Rod Forum : Hotrodders Bulletin Board

Hot Rod Forum : Hotrodders Bulletin Board (http://www.hotrodders.com/forum/)
-   Transmission - Rearend (http://www.hotrodders.com/forum/transmission-rearend/)
-   -   B&M Shift kit - Governor clicking (http://www.hotrodders.com/forum/b-m-shift-kit-governor-clicking-91423.html)

gilby246 06-10-2006 12:48 PM

B&M Shift kit - Governor clicking
 
I just got done doing a complete rebuild to my TH350 and installed a B&M shift improver kit street/strip. The transmission had no issues prior to the rebuild besides needing new clutches . After putting it all back together and taking the car for a ride I could hear the governor clicking. I jacked it up and turned the driveshaft by hand and could hear it. To verify I popped open the cover and could see it as it clicked (the weights falling) took it out to verify and it stopped. I replaced it with another, put it back together and its doing the same thing. I have since taken the valve body out to make sure the governor screen or line wasnít clogged but it was fine ( I replaced it anyway). Although there was fluid behind the cover I suspect that the governor is not getting full line feed but I donít know why.
I had a friend who builds transmissions for a living help me on this one and trust everything was done properly.
I donít know if this is shift kit related or another reasonÖany ideas or suggestions would be appreciated

BTW- In my frustration Im sure I left out some important info so please ask if more is needed

Crosley 06-10-2006 03:36 PM

you complain about clicking noise.

does the tranny NOT function correctly ?

No shifts?

soft shifts?

gilby246 06-10-2006 03:55 PM

Yes, I am complaining
it does work correctly... just sounds absolutly god awfull horrible under load and bad the rest of the time

Crosley 06-10-2006 05:30 PM

Quote:

Originally Posted by gilby246
Yes, I am complaining
it does work correctly... just sounds absolutly god awfull horrible under load and bad the rest of the time

if the tranny works correctly........

A governor is not going to sound
Quote:

absolutly god awfull horrible under load
you have other problems.

check for flywheel cracks , loose bolts , .

do you have a dust cover on the tranny at the flywheel? Is it a possible problem ?


All times are GMT -6. The time now is 12:00 PM.

Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.
Search Engine Optimization by vBSEO 3.6.0 PL2
Copyright Hotrodders.com 1999 - 2012. All Rights Reserved.