Backfire - Hot Rod Forum : Hotrodders Bulletin Board
Hotrodders.com -- Hot Rod Forum



Register FAQ Search Today's Posts Unanswered Posts Auto Escrow Insurance Auto Loans
Hot Rod Forum : Hotrodders Bulletin Board > Tech Help> Engine
User Name
Password
lost password?   |   register now

Reply
 
LinkBack Thread Tools
  #1 (permalink)  
Old 04-20-2004, 01:53 PM
caminoguy55's Avatar
Member
 
Join Date: Jan 2004
Location: Washington
Age: 66
Posts: 30
Wiki Edits: 0

Thanks: 0
Thanked 0 Times in 0 Posts
Backfire

I'm having difficulty getting rid of a WOT backfire. Running 350sbc, edelbrock 1406, Mallory HEI, mild cam and vortec heads. My timing is about 12-14 degrees static advance with 24 degrees mechanical. I have tried lighter springs in the HEI and different jets and rods in the carb. No luck yet. Any suggestions??

Thanks

    Advertisement
Reply With Quote Quick reply to this message
Sponsored Links
Advertisement
 
  #2 (permalink)  
Old 04-20-2004, 03:12 PM
Siggy_Freud's Avatar
Hotrodders.com Moderator
 
Last photo:
Join Date: Dec 2003
Location: Portland, Oregon
Age: 29
Posts: 2,371
Wiki Edits: 0

Thanks: 0
Thanked 1 Time in 1 Post
The 1406 is an economy designed carb. Does it do it when you go WOT from a dead stop or anytime you jump to WOT?

I was using a 1406 carb on my 350 and no matter what I did to the sucker it would always give me a pop from a stop to WOT.
__________________
Bringing history and technology together.
Reply With Quote Quick reply to this message
  #3 (permalink)  
Old 04-20-2004, 09:36 PM
caminoguy55's Avatar
Member
 
Join Date: Jan 2004
Location: Washington
Age: 66
Posts: 30
Wiki Edits: 0

Thanks: 0
Thanked 0 Times in 0 Posts
Siggy..That was exactly the problem, but today I solved it. I went a bought a Holly Street Avenger 670. Its like a new world. Maybe what they say about Edelbrock vs Holly is true. My guy at the parts store said he also had the same problem with a 600 Edelbrock. When he put new heads on the carb just wouldn't keep up. He tried everything too. Nothing worked until he put a Holly on it.

Caminoguy
Reply With Quote Quick reply to this message

Recent Engine posts with photos

Quick Reply
Message:
Options

Register Now

In order to be able to post messages on the Hot Rod Forum : Hotrodders Bulletin Board forums, you must first register.
Please enter your desired user name (usually not your first and last name), your email address and other required details in the form below.
User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.
Password:
Confirm Password:
Email Address
Please enter a valid email address for yourself.
Email Address:

Log-in

Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.




Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools

Posting Rules
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On



All times are GMT -6. The time now is 09:15 AM.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.
Search Engine Optimization by vBSEO 3.6.0 PL2
Copyright Hotrodders.com 1999 - 2012. All Rights Reserved.