bad fuel pump??? - Hot Rod Forum : Hotrodders Bulletin Board
Hotrodders.com -- Hot Rod Forum



Register FAQ Search Today's Posts Unanswered Posts Auto Escrow Insurance Auto Loans
Hot Rod Forum : Hotrodders Bulletin Board > Tech Help> Engine
User Name
Password
lost password?   |   register now

Reply
 
LinkBack Thread Tools
  #1 (permalink)  
Old 01-25-2008, 07:50 PM
elcaminodragster's Avatar
70 El Camino aka FRANKENSTEIN
 
Last photo:
Join Date: Feb 2007
Location: California
Age: 26
Posts: 738
Wiki Edits: 0

Thanks: 2
Thanked 0 Times in 0 Posts
bad fuel pump???

i have a 350sbc in a 70 elky. i have a edelbrock high performance fuel pump part #1721. for some reason there is zero fuel pressure. the pump isnt even a year old yet. the engine will idle but soon as you give it a bit of gas it dies. i have a cheapo little pressure gauge on it that gives you a good estimate on the pressure but right now its not even twitching. im gonna pull it off tomorrow and see if i can figure it out. if it is a bad fuel pump would it be better to rebuild it or just by a new one??? i have a 650 carb that needs 6psi and im pushing right around 400hp.


what is the best mechanical fuel pump for the street???

are edelbrock pumps crappy??? i mean this thing is pumping zero pressure and its not even a year old!

    Advertisement
Reply With Quote Quick reply to this message
Sponsored Links
Advertisement
 
  #2 (permalink)  
Old 01-25-2008, 08:28 PM
poncho62's Avatar
Out of the Loop Moderator
 
Last wiki edit: Streetbeasts links
Last journal entry: at car show
Last photo:
Join Date: Oct 2003
Location: Hanover, Ontario, Canada
Age: 62
Posts: 16,893
Wiki Edits: 5

Thanks: 20
Thanked 258 Times in 211 Posts
If the pump isnt old I would suspect that there is a problem in the fuel line from the tank. Check to see if there is fuel being drawn up through the line. I have seen where on older vehicles, the fuel line rusts out on top of the fuel tank......The pump then just sucks air....or very little fuel. Worth looking at.
__________________
Ontario Rodders

Budget RVs
Reply With Quote Quick reply to this message
  #3 (permalink)  
Old 01-26-2008, 11:05 AM
elcaminodragster's Avatar
70 El Camino aka FRANKENSTEIN
 
Last photo:
Join Date: Feb 2007
Location: California
Age: 26
Posts: 738
Wiki Edits: 0

Thanks: 2
Thanked 0 Times in 0 Posts
well the pump is ok its the fuel pump push rod. it is stuck in the block it wont come out all the way. so that means the top of the push rod is mushroomed!!! how do i get it out???
Reply With Quote Quick reply to this message
  #4 (permalink)  
Old 01-26-2008, 11:23 AM
poncho62's Avatar
Out of the Loop Moderator
 
Last wiki edit: Streetbeasts links
Last journal entry: at car show
Last photo:
Join Date: Oct 2003
Location: Hanover, Ontario, Canada
Age: 62
Posts: 16,893
Wiki Edits: 5

Thanks: 20
Thanked 258 Times in 211 Posts
Can't pull it out with vise grips?....Only other way is to remove the cam, push it up so you can grind the mushroomed part off. Then you need to find out why it got that way....Lack of lubrication?
__________________
Ontario Rodders

Budget RVs
Reply With Quote Quick reply to this message
  #5 (permalink)  
Old 01-26-2008, 11:27 AM
elcaminodragster's Avatar
70 El Camino aka FRANKENSTEIN
 
Last photo:
Join Date: Feb 2007
Location: California
Age: 26
Posts: 738
Wiki Edits: 0

Thanks: 2
Thanked 0 Times in 0 Posts
no i tried vise grips and it didnt do anything. well you just told me what i didnt want to hear but thank you. i guess its time to get to work.
Reply With Quote Quick reply to this message

Recent Engine posts with photos

Quick Reply
Message:
Options

Register Now

In order to be able to post messages on the Hot Rod Forum : Hotrodders Bulletin Board forums, you must first register.
Please enter your desired user name (usually not your first and last name), your email address and other required details in the form below.
User Name:
If you do not want to register, fill this field only and the name will be used as user name for your post.
Password
Please enter a password for your user account. Note that passwords are case-sensitive.
Password:
Confirm Password:
Email Address
Please enter a valid email address for yourself.
Email Address:

Log-in

Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.




Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools

Posting Rules
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On


Similar Threads
Thread Thread Starter Forum Replies Last Post
Help - my fuel pump is leaking KENMO Engine 10 07-01-2007 12:39 PM
HELP QUICK Electric Fuel Pump Leaking 66 T-Bird Engine 4 06-06-2005 06:26 AM
Which waterpump? Eagle1 Engine 5 08-06-2004 06:38 PM
Bad fuel pump??? ffcagle34 Engine 2 06-20-2004 11:15 PM
Lean backfire Camaro76 Engine 5 04-15-2003 05:45 PM


All times are GMT -6. The time now is 10:51 PM.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.
Search Engine Optimization by vBSEO 3.6.0 PL2
Copyright Hotrodders.com 1999 - 2012. All Rights Reserved.