Bad fuel pump??? - Hot Rod Forum : Hotrodders Bulletin Board
Hotrodders.com -- Hot Rod Forum



Register FAQ Search Today's Posts Unanswered Posts Auto Escrow Insurance Auto Loans
Hot Rod Forum : Hotrodders Bulletin Board > Tech Help> Engine
User Name
Password
lost password?   |   register now

Reply
 
LinkBack Thread Tools
  #1 (permalink)  
Old 06-20-2004, 09:49 PM
Member
 
Join Date: Oct 2002
Location: Bakersfield, CA
Posts: 60
Wiki Edits: 0

Thanks: 0
Thanked 0 Times in 0 Posts
Bad fuel pump???

You guys are awesome. I have a new problem though. 350 sbc with roch. 4 bbl carb. Engine runs for 2-3 minutes then dies. No fuel in visible fuel filter. Wait 5-10 minutes and engine fires up strong then dies after 2-3 minutes and fuel filter is dry again. Mechanical fuel pump.

Will a bad fuel pump work off and on again or is it another problem. Thanks

    Advertisement
Reply With Quote Quick reply to this message
Sponsored Links
Advertisement
 
  #2 (permalink)  
Old 06-20-2004, 11:05 PM
DoubleVision's Avatar
Not Considered a Senior Member
 
Last photo:
Join Date: Oct 2002
Location: Heart Of Dixie
Age: 40
Posts: 10,654
Wiki Edits: 0

Thanks: 15
Thanked 58 Times in 55 Posts
If your fuel pump has a return line, try this test, take a pair of vice grips and kink shut the return line, if the pump works fine then the pump is bad.
Reply With Quote Quick reply to this message
  #3 (permalink)  
Old 06-20-2004, 11:15 PM
troy-curt's Avatar
Shop Owner And Troll Hunter
 

Last journal entry: Detailing Eng. Compartment
Last photo:
Join Date: Apr 2003
Location: Prairie Grove Ar.
Age: 75
Posts: 2,646
Wiki Edits: 0

Thanks: 0
Thanked 0 Times in 0 Posts
Yep a failing pump can act that way. Also the filter sock in the tank could be stoped up.

Troy
__________________
If you don't make mistakes. your not doing anything.

69 ss rs full custom camaro 98 ISCA grandchampion
69 ss rs bb camaro wifes driver
66 Elcamino 350/all dz parts,ac,windows,loaded,my driver
69 ss chevelle bb conv.fresh frame off
26 T sedan street rod
Reply With Quote Quick reply to this message

Recent Engine posts with photos

Quick Reply
Message:
Options

Register Now

In order to be able to post messages on the Hot Rod Forum : Hotrodders Bulletin Board forums, you must first register.
Please enter your desired user name (usually not your first and last name), your email address and other required details in the form below.
User Name:
If you do not want to register, fill this field only and the name will be used as user name for your post.
Password
Please enter a password for your user account. Note that passwords are case-sensitive.
Password:
Confirm Password:
Email Address
Please enter a valid email address for yourself.
Email Address:

Log-in

Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.




Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools

Posting Rules
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On



All times are GMT -6. The time now is 06:30 PM.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.
Search Engine Optimization by vBSEO 3.6.0 PL2
Copyright Hotrodders.com 1999 - 2012. All Rights Reserved.