Bad Valve?? or bad carb? - Hot Rod Forum : Hotrodders Bulletin Board
Hotrodders.com -- Hot Rod Forum



Register FAQ Search Today's Posts Unanswered Posts Auto Escrow Insurance Auto Loans
Hot Rod Forum : Hotrodders Bulletin Board > Tech Help> Engine
User Name
Password
lost password?   |   register now

Reply
 
LinkBack Thread Tools
  #1 (permalink)  
Old 02-12-2013, 10:08 AM
Registered User
 
Join Date: Feb 2013
Posts: 2
Wiki Edits: 0

Thanks: 1
Thanked 0 Times in 0 Posts
Bad Valve?? or bad carb?

My 1985 350 sbc has ping/knock. The engine was rebuilt about 5 years ago. It has a mild cam and edelbrock intake. It started knocking about month ago. Been parked since.
When i give it gas under load she knocks and has little power. It sounds like its on the driver side. Its not a loud knock its just kinda there. But ive tried everything, adjusting the valves. advancing and retarding the timing. New plugs and wires. But the fuel filter was clogged bad. So i changed that out and still the same. She sounds like its missing the way the exhaust sounds on the driver side.(dual exhaust) but the passenger side sounds normal. I need input here.. Bad exhaust valve??Bad carb?? Spark Knock?

    Advertisement
Reply With Quote Quick reply to this message
Sponsored Links
Advertisement
 
  #2 (permalink)  
Old 02-12-2013, 10:35 AM
vinniekq2's Avatar
Registered User
 
Join Date: Jun 2012
Location: BC,Canada
Age: 56
Posts: 7,423
Wiki Edits: 0

Thanks: 292
Thanked 708 Times in 683 Posts
compression test/leak down test
Reply With Quote Quick reply to this message
The Following User Says Thank You to vinniekq2 For This Useful Post:
OldSchool350 (02-12-2013)
  #3 (permalink)  
Old 02-12-2013, 02:10 PM
RWENUTS's Avatar
Registered User
 
Last photo:
Join Date: Nov 2011
Location: Nanaimo, BC, Canada
Age: 62
Posts: 1,874
Wiki Edits: 0

Thanks: 47
Thanked 200 Times in 189 Posts
Flat cam!!
Reply With Quote Quick reply to this message
  #4 (permalink)  
Old 02-12-2013, 02:49 PM
T-bucket23's Avatar
Hotrodders.com Moderator
 
Last wiki edit: Engine basic condition - how to check Last photo:
Join Date: Aug 2005
Location: Massachusetts
Age: 56
Posts: 5,097
Wiki Edits: 26

Thanks: 7
Thanked 103 Times in 88 Posts
Carbon buildup, broken valve spring, flat cam. I would start it with the valve cover off and see if everything is moving to start with.
__________________
Artificial Intelligence is no match for Natural Stupidity



Chet
Reply With Quote Quick reply to this message
  #5 (permalink)  
Old 02-12-2013, 06:32 PM
Registered User
 
Join Date: Feb 2013
Posts: 2
Wiki Edits: 0

Thanks: 1
Thanked 0 Times in 0 Posts
All the valve springs move and the valves are set at 0-lash. Seems to me like one of the cylinders are not combusting right. i think ill go with vinnies opinion. Just need me compression tester now
Reply With Quote Quick reply to this message

Recent Engine posts with photos

Quick Reply
Message:
Options

Register Now

In order to be able to post messages on the Hot Rod Forum : Hotrodders Bulletin Board forums, you must first register.
Please enter your desired user name (usually not your first and last name), your email address and other required details in the form below.
User Name:
If you do not want to register, fill this field only and the name will be used as user name for your post.
Password
Please enter a password for your user account. Note that passwords are case-sensitive.
Password:
Confirm Password:
Email Address
Please enter a valid email address for yourself.
Email Address:

Log-in

Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.




Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools

Posting Rules
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On


Similar Threads
Thread Thread Starter Forum Replies Last Post
Bad Valve?...How do you tell? High School Hot Rod Engine 11 06-21-2010 09:25 PM
Bad Valve?...How do you tell? High School Hot Rod Engine 2 06-18-2010 11:04 PM
Bad Cam, Bad, Bad, 327 MosinNagant Engine 6 12-30-2009 07:56 PM
Bad valve mudkat Engine 3 04-05-2007 05:35 PM
Tightened My Valve Train.........(One Bad Valve?) white66coupe Engine 1 08-23-2004 09:00 PM


All times are GMT -6. The time now is 09:39 PM.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.
Search Engine Optimization by vBSEO 3.6.0 PL2
Copyright Hotrodders.com 1999 - 2012. All Rights Reserved.