Hot Rod Forum : Hotrodders Bulletin Board - View Single Post - Battery went dead sitting, What to check?
View Single Post
  #1 (permalink)  
Old 06-30-2011, 05:34 PM
eric32 eric32 is offline
Registered User
 
Last photo:
Join Date: May 2008
Location: ohio
Posts: 1,369
Wiki Edits: 0

Thanks: 17
Thanked 36 Times in 34 Posts
Battery went dead sitting, What to check?

Hello guys I went out to start my truck today and for some reason my battery was almost dead at only 10 volts showing when you turn the key forward in the start position so I know something drained it. I had to get a jump.

This is a carbureted v8 96 s10 and not using any gauges in dash area as I have a set of aftermarket gauges. I drove my truck last Friday and everything was charging and working just fine with no issues. I have not driven it since then. Everything on charging system is brand new and battery is less then two years old and it was fully charged last week.

I did have some sort of problem with my chime staying on while the dash light was on while running headlights but if I turned the dash light dimmer switch to the off position to shut dash light off it would go off. Now while running the lights the chime sometimes would keep quiet. Anyways that should not be the problem as the only change I did to my truck since last week was take out the chime box under my dash and nothing else.

I looked over everything in my truck and there was no light's on inside anywhere and the key was in the correct position when I took it out. Now I don't know if this is causing the drain or not but on my dash there is nothing on but for some reason the battery indicator light stays on even with no keys in the truck and heck I never paid attention before but to me it seems that should not be showing with nothing on or running correct?

So if this is the problem can just that little indicator not shutting off drain my battery by not wanting to shut off? I never paid attention before cause only gauge that works in dash is the volt gauge. Hope someone can help me out on what the heck to check for cause everything else is working as normal and all lights turn off when the key is off.

Thanks guys
Eric
Reply With Quote