Hot Rod Forum : Hotrodders Bulletin Board - View Single Post - bc/cc help please
View Single Post
  #1 (permalink)  
Old 08-22-2012, 12:48 AM
lifted08sierra lifted08sierra is offline
Registered User
 
Join Date: Aug 2012
Posts: 3
Wiki Edits: 0

Thanks: 0
Thanked 0 Times in 0 Posts
bc/cc help please

Im new to this forum, seems to be some very experienced people here so chime in!!

Ive been painting cars for about 5 years now and have had some great results, however I needed a place to spray my current project and my close friends grandfather said he would just paint it for me as long as i prepped the car, seeing some of his work it seemed like a good idea to me. We used a omni base, Electron Blue Pearl, shopline (jc620) clear, slow reducer for base, slow hardener for clear. Put the base on and besides some slight base runs, looked good, so on to clear we went. Did one nice heavy coat waited about an hour (seemed too long for my liking, dry to the touch) laid down some more clear, well I noticed some cracking/lifting so we stopped. I come back the following day to see my car all color sanded and several spots sanded clear down to the primer. I went through and wet sanded the entire car with 1000, untapped and left it outside to cure. I bought more base today and have a gallon of clear left over from another project, I am going to be spraying the car this time around.. However I am not sure on how long to let this cure before i get into laying more base over this. The car was painted Sunday night, temps have been in the mid to upper 80s. Any advice on this would be greatly appreciated as I am not positive on laying more base over fresh clear. It has been wet sanded with 400 at first, then I wet sanded with 1000 so its been opened a little bit. Thank you!
Reply With Quote