Belvedere Wiring - Hot Rod Forum : Hotrodders Bulletin Board
Hotrodders.com -- Hot Rod Forum



Register FAQ Search Today's Posts Unanswered Posts Auto Escrow Insurance Auto Loans
Hot Rod Forum : Hotrodders Bulletin Board > Tech Help> Electrical
User Name
Password
lost password?   |   register now

Reply
 
LinkBack Thread Tools
  #1 (permalink)  
Old 05-21-2003, 05:38 AM
New Member
 
Join Date: Apr 2003
Location: Middle Georgia
Posts: 15
Wiki Edits: 0

Thanks: 0
Thanked 0 Times in 0 Posts
Post Belvedere Wiring

I'm having trouble finding a wiring diagram for the engine compartment of a '66 Belvedere. There are a buch of cut wires and spliced wires using differing colors. Can anyone help me find a diagram on the web?
Reply With Quote Quick reply to this message
Sponsored Links
Advertisement
 
  #2 (permalink)  
Old 05-21-2003, 07:27 PM
Member
 
Last photo:
Join Date: Aug 2002
Location: Alabama
Posts: 592
Wiki Edits: 0

Thanks: 0
Thanked 4 Times in 4 Posts
Post

I have a 65 plymouth belvedere II with a 273 engine and automatic transmission. If you need specific informaiton and I can locate the wires you are talking about, I will help you if I can. For general information you might try moparts.com. Hope this helps.
Reply With Quote Quick reply to this message
  #3 (permalink)  
Old 05-23-2003, 07:48 PM
New Member
 
Join Date: Apr 2003
Location: Middle Georgia
Posts: 15
Wiki Edits: 0

Thanks: 0
Thanked 0 Times in 0 Posts
Post

Thanks. I tried moparts.com and someone had posted a wiring diagram there so I sownloaded it. Now, out to the garage!!!
Reply With Quote Quick reply to this message
  #4 (permalink)  
Old 07-07-2003, 03:14 PM
Registered User
 
Join Date: Jul 2003
Location: camp lejeune
Age: 34
Posts: 1
Wiki Edits: 0

Thanks: 0
Thanked 0 Times in 0 Posts
Angry 65 belvedere II wiring diagram

i have a 65 belvedere II that originaly had a 383 in it. i put a 440 in it. i am wanting to rewire it. i am looking for a wiring diagram to assist me. i am also trying to find a suitable wat to remove the dash mount screws next to the windshield. any help with either problem would be great.
Reply With Quote Quick reply to this message

Recent Electrical posts with photos

Quick Reply
Message:
Options

Register Now

In order to be able to post messages on the Hot Rod Forum : Hotrodders Bulletin Board forums, you must first register.
Please enter your desired user name (usually not your first and last name), your email address and other required details in the form below.
User Name:
If you do not want to register, fill this field only and the name will be used as user name for your post.
Password
Please enter a password for your user account. Note that passwords are case-sensitive.
Password:
Confirm Password:
Email Address
Please enter a valid email address for yourself.
Email Address:

Log-in

Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.




Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools

Posting Rules
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On



All times are GMT -6. The time now is 03:43 AM.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.
Search Engine Optimization by vBSEO 3.6.0 PL2
Copyright Hotrodders.com 1999 - 2012. All Rights Reserved.