BG Speed Demon Choke problem - Hot Rod Forum : Hotrodders Bulletin Board
Hotrodders.com -- Hot Rod Forum



Register FAQ Search Today's Posts Unanswered Posts Auto Escrow Insurance Auto Loans
Hot Rod Forum : Hotrodders Bulletin Board > Tech Help> Engine
User Name
Password
lost password?   |   register now

Reply
 
LinkBack Thread Tools
  #1 (permalink)  
Old 02-01-2006, 08:28 AM
malc's Avatar
Living At The Speed Of Life
 
Last photo:
Join Date: Jun 2003
Location: Espaņa Right Coast
Age: 63
Posts: 3,240
Wiki Edits: 0

Thanks: 86
Thanked 68 Times in 65 Posts
BG Speed Demon Choke problem

I installed my carb and did not notice that the gasket on the choke side needed to be trimmed to the carb baseplate shape. This resulted in the choke mechanism not being able to function properly.
I noticed the mistake but after cutting the gasket back the choke still failed to operate, the plate closed but the high idle did not work.
I dismantled the whole issue right down to removing the parts off the throttle shaft.
This was fun, as the outer part left the scene and now resides in the front crossmember, to be picked out later. I had a new choke kit on hand so I could continue.
I found out the throttle shaft is very slack and can be moved up and down with fingers and fuel is leaking from there.
Not being able to do more I reassembled the choke, but the parts on the end of the throttle shaft needed to have a washer placed between them and the carb, see attachment.
The whole setup was very slack and caused the choke not to initiate high idle as the two parts did not engage.
I would like to ask tech@BG if he thinks this fix is good and to point out the instructions for installing the choke, especially the two pieces and spring on the shaft are not very clear.
I´m not climbing on the BG bashing train just pointing out a picky problem.
Attached Thumbnails
Click image for larger version

Name:	BG_carb_5.jpg
Views:	113
Size:	237.6 KB
ID:	9753  

    Advertisement
Reply With Quote Quick reply to this message
Sponsored Links
Advertisement
 
  #2 (permalink)  
Old 02-01-2006, 01:48 PM
Registered User
 
Join Date: Nov 2005
Location: usa
Posts: 17
Wiki Edits: 0

Thanks: 0
Thanked 0 Times in 0 Posts
i've had a similar issue with my choke on my demon the fast idle was not working after trying differnt things and getting fed up i just sent it back to BG. and they fixed it up for me they said choke was not functioning properly and the pump arm was rubbing the endplate. seems to be fine now.
Reply With Quote Quick reply to this message
  #3 (permalink)  
Old 02-02-2006, 07:40 AM
Technical Support Barry Grant
 
Last photo:
Join Date: Jul 2003
Location: Dahlonega, GA
Posts: 1,503
Wiki Edits: 0

Thanks: 0
Thanked 0 Times in 0 Posts
Choke Problem

Malc,

The metal bracket that holds the fast idle speed screw is thin, and can bend if caught up on the gasket. Installing the washer as you have will prevent it from bending, so you should be good to go.
Reply With Quote Quick reply to this message

Recent Engine posts with photos

Quick Reply
Message:
Options

Register Now

In order to be able to post messages on the Hot Rod Forum : Hotrodders Bulletin Board forums, you must first register.
Please enter your desired user name (usually not your first and last name), your email address and other required details in the form below.
User Name:
If you do not want to register, fill this field only and the name will be used as user name for your post.
Password
Please enter a password for your user account. Note that passwords are case-sensitive.
Password:
Confirm Password:
Email Address
Please enter a valid email address for yourself.
Email Address:

Log-in

Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.




Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools

Posting Rules
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On


Similar Threads
Thread Thread Starter Forum Replies Last Post
speed demon problems gr8z28 Engine 27 11-09-2005 07:24 PM
More BG Speed Demon questions Jacks77 Engine 21 08-18-2005 04:58 PM
Barry Grant 750 Speed Demon hestitation Jacks77 Engine 13 08-16-2005 08:09 AM
Speed Demon 850 Rhansen Engine 2 08-14-2005 10:56 AM
Saganaw 4 speed with speedo problem JRinTX Transmission - Rearend 1 07-12-2003 06:23 PM


All times are GMT -6. The time now is 05:05 PM.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.
Search Engine Optimization by vBSEO 3.6.0 PL2
Copyright Hotrodders.com 1999 - 2012. All Rights Reserved.