Hot Rod Forum : Hotrodders Bulletin Board

Hot Rod Forum : Hotrodders Bulletin Board (http://www.hotrodders.com/forum/)
-   Suspension - Brakes - Steering (http://www.hotrodders.com/forum/suspension-brakes-steering/)
-   -   Bleeding Hydroboost (http://www.hotrodders.com/forum/bleeding-hydroboost-219052.html)

Blazin72 05-06-2012 01:37 PM

Bleeding Hydroboost
 
Guys, I was driving my truck around my property this morning and as I turned the steering wheel sharply to one direction the system started making a loud knocking noise. As I stepped on the brakes to stop the truck the system made more noise and braking effort was hard. I parked the truck next to the shop and checked the power steering pump. It turns out the reservoir was very low (meaning nearly empty). I added fluid and now I have some hydraulic assist on the brakes again. The power steering never lost assist. The problem now is that I suspect there is air in the system and it makes a lot of noise as I turn the wheel or step on the brakes. The truck is a 2000 Silverado 2500 with 139,000 miles and I haven't had any issues with pump noise, brake or power assist until this incident this morning. I don't see any fluid on the ground so I don't think anything ruptured. I did find that the pump appears to be weeping and I think this is mostly a failure on my part to periodically check the fluid level in the pump.

I've never had to work on one of these systems, how would I go about bleeding it?

LATECH 05-06-2012 01:55 PM

I dont think its a bleed problem, they bleed themselves. They also have an accumultor (pressurized cylinder) that stores pressure if the pump pressue is lost or the engine stalls and pump quits turning. It supplies assist for the brakes if such a condition occurs. The accumulator is the big round cylinder shaped thing on the hydra boost.
sounds to me like you need to install a new hydra boost.I would also check the pressure valve in the pump( inside the pump, behind the pressure line fitting) if it has debris in there it too can cause issues.

cobalt327 05-07-2012 01:07 AM

Quote:

Originally Posted by Blazin72
Guys, I was driving my truck around my property this morning and as I turned the steering wheel sharply to one direction the system started making a loud knocking noise. As I stepped on the brakes to stop the truck the system made more noise and braking effort was hard. I parked the truck next to the shop and checked the power steering pump. It turns out the reservoir was very low (meaning nearly empty). I added fluid and now I have some hydraulic assist on the brakes again. The power steering never lost assist. The problem now is that I suspect there is air in the system and it makes a lot of noise as I turn the wheel or step on the brakes. The truck is a 2000 Silverado 2500 with 139,000 miles and I haven't had any issues with pump noise, brake or power assist until this incident this morning. I don't see any fluid on the ground so I don't think anything ruptured. I did find that the pump appears to be weeping and I think this is mostly a failure on my part to periodically check the fluid level in the pump.

I've never had to work on one of these systems, how would I go about bleeding it?

Check this, but turning the wheels from lock to lock several times will bleed an ordinary PS pump...

It might be easier on the system to do this w/the front wheels off the ground or when rolling slowly.

Blazin72 05-07-2012 06:27 AM

Thanks, I'll look at it tonight.

When I put the truck back in the shop last night the power steering started acting up too. Turning the steering wheel to one side or the other caused the wheel to respond pretty erratically, either trying to pull harder or do little or nothing at all. I thought about it some and it's not really the hydroboost unit itself that seems to be an issue. I had a friend look at it with me last night and the noise is coming from the pump.

cobalt327 05-07-2012 08:38 AM

Well, if air got into the system, it can be noisy and erratic feeling until the air is expelled. If the fluid was frothy, it will have had time for that air to have left the fluid. I'm wondering if there might be more air still trapped inside the pump or lines... of course the pump may have taken a dump on you. :smash:

Blazin72 05-07-2012 05:06 PM

Quote:

Originally Posted by cobalt327
of course the pump may have taken a dump on you. :smash:

That's my concern. I wonder if they are rebuildable? I think the pump is cheaper than the hydroboost unit too which is another reason I really hope it's a pump problem.

Blazin72 05-15-2012 10:36 PM

Just an update. Replaced the power steering pump. Problem solved.


All times are GMT -6. The time now is 07:41 AM.

Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.
Search Engine Optimization by vBSEO 3.6.0 PL2
Copyright Hotrodders.com 1999 - 2012. All Rights Reserved.