Bog at launch - Hot Rod Forum : Hotrodders Bulletin Board
Hotrodders.com -- Hot Rod Forum



Register FAQ Search Today's Posts Unanswered Posts Auto Escrow Insurance Auto Loans
Hot Rod Forum : Hotrodders Bulletin Board > Tech Help> Engine
User Name
Password
lost password?   |   register now

Reply
 
LinkBack Thread Tools
  #1 (permalink)  
Old 02-18-2006, 01:09 AM
oregon chevelle's Avatar
Member
 
Last photo:
Join Date: Jul 2005
Location: oregon
Age: 50
Posts: 139
Wiki Edits: 0

Thanks: 0
Thanked 0 Times in 0 Posts
Bog at launch

Hi all, Here is the issue I am having. My Car weighs 3600 lbs with me in it. It has 3.08 gears and a Richmond T-10 four speed manual. The engine has Trick flow 31400001 aluminum heads and a cam of 216 duration @ .050 and a 454 lift. I usually launch at 4000-4500 rpm. If the car hooks very well I get a bog and then it takes off. If I don't hook to well the revs stay up and I actually ET better. The carb is a Eddy 1406. I am sure the 3.08s do not help but is that the cause of the bog or is it a carb problem?

    Advertisement
Reply With Quote Quick reply to this message
Sponsored Links
Advertisement
 
  #2 (permalink)  
Old 02-18-2006, 06:03 PM
Registered User
 
Last photo:
Join Date: Dec 2005
Location: California
Age: 67
Posts: 36
Wiki Edits: 0

Thanks: 0
Thanked 0 Times in 0 Posts
Check the carb first. The accelerator pump could be the culprit. The Edelbrock has three positions on the pump lever. Try the shortest throw and see if that helps. They also sell replacement squirter's in larger sizes. More cam means more carb. Even with 3.08s, launching at 4000 to 4500 should get you moving with minimum bog.

Oljoedog

Live long race hard
Reply With Quote Quick reply to this message
  #3 (permalink)  
Old 02-18-2006, 06:22 PM
41willys's Avatar
Blowin' it
 
Last wiki edit: Choosing a trailer
Last journal entry: Running again...
Last photo:
Join Date: Aug 2002
Location: Katy, Texas
Age: 39
Posts: 417
Wiki Edits: 11

Thanks: 0
Thanked 0 Times in 0 Posts
Quote:
Originally Posted by oregon chevelle
Hi all, Here is the issue I am having. My Car weighs 3600 lbs with me in it. It has 3.08 gears and a Richmond T-10 four speed manual. The engine has Trick flow 31400001 aluminum heads and a cam of 216 duration @ .050 and a 454 lift. I usually launch at 4000-4500 rpm. If the car hooks very well I get a bog and then it takes off. If I don't hook to well the revs stay up and I actually ET better. The carb is a Eddy 1406. I am sure the 3.08s do not help but is that the cause of the bog or is it a carb problem?

I would also check to see if fuel slosh is the culprit. Depending on where the fuel system is picking up the fuel. When the fuel sloshes to the rear of tank, the pick up could be not submerged depending if it is that style pump. Is it submerged or is it a line at the bottom of the tank? If it is a line, is it in the rear of the tank?
Reply With Quote Quick reply to this message
  #4 (permalink)  
Old 02-20-2006, 06:28 PM
oregon chevelle's Avatar
Member
 
Last photo:
Join Date: Jul 2005
Location: oregon
Age: 50
Posts: 139
Wiki Edits: 0

Thanks: 0
Thanked 0 Times in 0 Posts
Hmm I am not sure of all the carb stuff you suggested, but I will start reading up on it and see if I cna get it done.
Reply With Quote Quick reply to this message
  #5 (permalink)  
Old 02-20-2006, 10:02 PM
Malibu73's Avatar
'68 Chevelle Malibu Sedan
 
Last photo:
Join Date: Aug 2004
Location: Oregon
Age: 26
Posts: 353
Wiki Edits: 0

Thanks: 0
Thanked 0 Times in 0 Posts
A little off topic, but where abouts in Oregon do you live?


P.S., I'm getting a slight off-idle bog in my chevelle, but that's because the primary jets are too rich...
Reply With Quote Quick reply to this message
  #6 (permalink)  
Old 02-20-2006, 11:18 PM
oregon chevelle's Avatar
Member
 
Last photo:
Join Date: Jul 2005
Location: oregon
Age: 50
Posts: 139
Wiki Edits: 0

Thanks: 0
Thanked 0 Times in 0 Posts
I live in Grants Pass
Reply With Quote Quick reply to this message
  #7 (permalink)  
Old 02-20-2006, 11:23 PM
Malibu73's Avatar
'68 Chevelle Malibu Sedan
 
Last photo:
Join Date: Aug 2004
Location: Oregon
Age: 26
Posts: 353
Wiki Edits: 0

Thanks: 0
Thanked 0 Times in 0 Posts
Quote:
Originally Posted by oregon chevelle
I live in Grants Pass

Son of a gun, I went by there twice, only I was more east on Hwy 97
Reply With Quote Quick reply to this message
  #8 (permalink)  
Old 02-20-2006, 11:32 PM
oregon chevelle's Avatar
Member
 
Last photo:
Join Date: Jul 2005
Location: oregon
Age: 50
Posts: 139
Wiki Edits: 0

Thanks: 0
Thanked 0 Times in 0 Posts
Yeah how lang ago did you go by? I get up to Portland a couple times a year. Hey if you here of anyone wanting to sell a 78-81 two door malibu give me a shout. I am looking for one of those. Gonna be a street/strip car or just strip depends on what shape it is in.
Reply With Quote Quick reply to this message
  #9 (permalink)  
Old 02-21-2006, 12:39 AM
Malibu73's Avatar
'68 Chevelle Malibu Sedan
 
Last photo:
Join Date: Aug 2004
Location: Oregon
Age: 26
Posts: 353
Wiki Edits: 0

Thanks: 0
Thanked 0 Times in 0 Posts
Quote:
Originally Posted by oregon chevelle
Yeah how lang ago did you go by? I get up to Portland a couple times a year. Hey if you here of anyone wanting to sell a 78-81 two door malibu give me a shout. I am looking for one of those. Gonna be a street/strip car or just strip depends on what shape it is in.
I went by there yesterday and today

I'll keep my eye out for somebody that wants to sell or is selling one.

I have a '73 Chevelle Malibu sedan with a 355 sbc.

It's a Ford green off of a '58 ford pickup with pearl in it, it's I nice color in my opinion.

My friend calls it a 'booger', but he's just jealous because his lemans is sitting up at his house rusting away with mice eating out his seats and he has no money.
Reply With Quote Quick reply to this message

Recent Engine posts with photos

Quick Reply
Message:
Options

Register Now

In order to be able to post messages on the Hot Rod Forum : Hotrodders Bulletin Board forums, you must first register.
Please enter your desired user name (usually not your first and last name), your email address and other required details in the form below.
User Name:
If you do not want to register, fill this field only and the name will be used as user name for your post.
Password
Please enter a password for your user account. Note that passwords are case-sensitive.
Password:
Confirm Password:
Email Address
Please enter a valid email address for yourself.
Email Address:

Log-in

Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.




Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools

Posting Rules
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On


Similar Threads
Thread Thread Starter Forum Replies Last Post
Holley Bog - Accelerator Pump Cam skizot Engine 6 12-27-2004 05:41 PM
is this possable bog? Brian Morency Engine 11 11-10-2004 03:33 PM
Bog off idle 66truck4spd Engine 9 05-07-2004 02:04 PM
1 st to 2 nd bog john69 Engine 2 06-25-2003 09:28 PM
Eibach Drag Launch Springs? stonedchihuahua Suspension - Brakes - Steering 0 11-18-2002 12:28 AM


All times are GMT -6. The time now is 09:23 AM.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.
Search Engine Optimization by vBSEO 3.6.0 PL2
Copyright Hotrodders.com 1999 - 2012. All Rights Reserved.