Brake lights - Hot Rod Forum : Hotrodders Bulletin Board
Hotrodders.com -- Hot Rod Forum



Register FAQ Search Today's Posts Unanswered Posts Auto Escrow Insurance Auto Loans
Hot Rod Forum : Hotrodders Bulletin Board > Tech Help> Electrical
User Name
Password
lost password?   |   register now

Reply
 
LinkBack Thread Tools
  #1 (permalink)  
Old 08-10-2007, 07:54 PM
Registered User
 
Join Date: Aug 2007
Location: Sacramento
Posts: 5
Wiki Edits: 0

Thanks: 0
Thanked 0 Times in 0 Posts
Brake lights

ok i have a 1966 chevy fleetside and the rear left side brake light is having some problems. When i turn on the turn signals it comes on and works fine, but when i press the brake it doesn't come on. I traced the whole freakin brake light wire all the way onto the cab, and found NO breaks in the wire, i can check again but i'm sure its solid, if you have any suggestions on what it would be just tell me and i would be VERY happy, but if not i can jsut bring it into a shop and see if they can find it.

Thank you
TJ

    Advertisement
Reply With Quote Quick reply to this message
Sponsored Links
Advertisement
 
  #2 (permalink)  
Old 08-10-2007, 08:25 PM
T-bucket23's Avatar
Hotrodders.com Moderator
 
Last wiki edit: Engine basic condition - how to check Last photo:
Join Date: Aug 2005
Location: Massachusetts
Age: 57
Posts: 5,154
Wiki Edits: 26

Thanks: 7
Thanked 109 Times in 94 Posts
Turn signal switch could be bad. The brake lights go through it.
Maybe someone here has a schematic for you.
Reply With Quote Quick reply to this message
  #3 (permalink)  
Old 08-10-2007, 09:19 PM
Cape Cod Bob's Avatar
Registered User
 
Last wiki edit: How to title a hot rod Last photo:
Join Date: Jul 2007
Location: MA
Posts: 1,125
Wiki Edits: 1

Thanks: 0
Thanked 26 Times in 18 Posts
trhttp://vccachat.org/forum/ubbthreads.php?ubb=cfrm&c=4
try posting your ? here
Reply With Quote Quick reply to this message
  #4 (permalink)  
Old 08-10-2007, 09:30 PM
docvette's Avatar
Hotrodders.com Moderator
 
Last wiki edit: Rebuild an alternator Last photo:
Join Date: Mar 2004
Location: Lafayette, california
Age: 62
Posts: 7,362
Wiki Edits: 12

Thanks: 0
Thanked 6 Times in 3 Posts
Doc here,

Sounds like the Column Plug may be dirty, corroded,or not properly seated..pull, clean, burnish and inspect the connectors.

Next step would be the left half of the turnsignal switch may be bad or intermittent..clean the contacts, inspect the connections (at the switch), and inspect the movement of the "Reset" tang as it returns to the center position..1/2 of that 1/2 of the switch is Brakelamp..the other 1/2 of that 1/2 is turnsignal..the centerwiper is the bulb itself...The whole OTHER half is the RIGHT side..

The switch provides the needed Isolation Between the two systems..


Doc
__________________
Aftermarket Solutions
Electronic & Electrical
Innovations
Reply With Quote Quick reply to this message
  #5 (permalink)  
Old 08-10-2007, 11:09 PM
Registered User
 
Join Date: Aug 2007
Location: Sacramento
Posts: 5
Wiki Edits: 0

Thanks: 0
Thanked 0 Times in 0 Posts
hey thanks!! ok tomarrow i will try both of those things and get back to you
Reply With Quote Quick reply to this message

Recent Electrical posts with photos

Quick Reply
Message:
Options

Register Now

In order to be able to post messages on the Hot Rod Forum : Hotrodders Bulletin Board forums, you must first register.
Please enter your desired user name (usually not your first and last name), your email address and other required details in the form below.
User Name:
If you do not want to register, fill this field only and the name will be used as user name for your post.
Password
Please enter a password for your user account. Note that passwords are case-sensitive.
Password:
Confirm Password:
Email Address
Please enter a valid email address for yourself.
Email Address:

Log-in

Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.




Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools

Posting Rules
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On


Similar Threads
Thread Thread Starter Forum Replies Last Post
voltage to tail lights vs brake lights? stratt134 Electrical 12 06-10-2006 06:51 PM
brake lights stay on.... jmtw Electrical 6 03-06-2005 07:48 AM
Wheel clunking and brake squeal skizot Suspension - Brakes - Steering 29 10-09-2004 06:17 AM
Hotrodders Knowledge Cluster: Disc Brake Conversions Jon Suspension - Brakes - Steering 0 08-29-2003 03:34 PM
Brake Lights 53chev Electrical 4 12-10-2002 03:49 PM


All times are GMT -6. The time now is 04:06 PM.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.
Search Engine Optimization by vBSEO 3.6.0 PL2
Copyright Hotrodders.com 1999 - 2012. All Rights Reserved.