Brake Lights wont Light! - Hot Rod Forum : Hotrodders Bulletin Board
Hotrodders.com -- Hot Rod Forum



Register FAQ Search Today's Posts Unanswered Posts Auto Escrow Insurance Auto Loans
Hot Rod Forum : Hotrodders Bulletin Board > Tech Help> Electrical
User Name
Password
lost password?   |   register now

Reply
 
LinkBack Thread Tools
  #1 (permalink)  
Old 06-29-2003, 12:23 PM
Registered User
 
Join Date: Jun 2003
Location: Baton Rouge, LA
Posts: 2
Wiki Edits: 0

Thanks: 0
Thanked 0 Times in 0 Posts
Cool Brake Lights wont Light!

OK, Here is the deal. 1997 Mustang GT Convertible. Brake lights don't work, not even the extra light on the trunk. We have checked all of the fuses and the bulbs and replace the Brake Light Switch on the Brake pedal. Are there any other obvious things to check? and could it be the wire?

    Advertisement
Reply With Quote Quick reply to this message
Sponsored Links
Advertisement
 
  #2 (permalink)  
Old 06-29-2003, 01:52 PM
Forkliftguy's Avatar
Crazy Canadian, woohooooo!
 
Last photo:
Join Date: May 2003
Location: Sudbury, Ontario
Age: 37
Posts: 175
Wiki Edits: 0

Thanks: 0
Thanked 0 Times in 0 Posts
Have you checked you checked to make sure there is power going to brake light switch? (Just a thought considering the fact that it is all of the lights not working and not just one.) If there is, I would check to make sure that all the connectors that connect the wire harness travelling to the back of the car aren't unplugged and/or the brake light wire hasn't popped out of any of these harnesses. HTH



Marc
Reply With Quote Quick reply to this message
  #3 (permalink)  
Old 07-01-2003, 07:43 AM
Registered User
 
Join Date: Jun 2003
Location: Baton Rouge, LA
Posts: 2
Wiki Edits: 0

Thanks: 0
Thanked 0 Times in 0 Posts
Thanks for the reply!

Thanks Forkliftguy!
NEW DEVELOPMENT:
Fuses are all good, but one fuse was missing. Replaced #9 15amp fuse and the Hazard lights Started blinking. Checked Hazard switch wouldn't turn them off. Removed Hazzard switch, still wouldnt turn them off. Replaced Signal Flasher, still blinking...
There is power going to Brake switch. The #9 fuse is the Brake fuse, Why would this make the Flashers blink uncontrolably!!!!
Completely confused
Reply With Quote Quick reply to this message
  #4 (permalink)  
Old 07-01-2003, 10:36 AM
awsum34's Avatar
Member
 
Last photo:
Join Date: Nov 2001
Location: Overland Park Ks
Age: 65
Posts: 369
Wiki Edits: 0

Thanks: 0
Thanked 0 Times in 0 Posts
There should be 2 flashers, one for the turns and one for the hazards.
Reply With Quote Quick reply to this message
  #5 (permalink)  
Old 07-01-2003, 11:41 AM
rnpit's Avatar
Member
 
Join Date: Jun 2003
Location: NJ
Age: 64
Posts: 53
Wiki Edits: 0

Thanks: 0
Thanked 0 Times in 0 Posts
Sounds like you have a problem in your directional signal switch. Also check to see if your year has a bcm (body control module)your problem may be in there. I you have access to a scanner it may show up on it.
Reply With Quote Quick reply to this message

Recent Electrical posts with photos

Quick Reply
Message:
Options

Register Now

In order to be able to post messages on the Hot Rod Forum : Hotrodders Bulletin Board forums, you must first register.
Please enter your desired user name (usually not your first and last name), your email address and other required details in the form below.
User Name:
If you do not want to register, fill this field only and the name will be used as user name for your post.
Password
Please enter a password for your user account. Note that passwords are case-sensitive.
Password:
Confirm Password:
Email Address
Please enter a valid email address for yourself.
Email Address:

Log-in

Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.




Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools

Posting Rules
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On



All times are GMT -6. The time now is 08:45 AM.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.
Search Engine Optimization by vBSEO 3.6.0 PL2
Copyright Hotrodders.com 1999 - 2012. All Rights Reserved.