brake lockup - Hot Rod Forum : Hotrodders Bulletin Board
Hotrodders.com -- Hot Rod Forum



Register FAQ Search Today's Posts Unanswered Posts Auto Escrow Insurance Auto Loans
Hot Rod Forum : Hotrodders Bulletin Board > Tech Help> Suspension - Brakes - Steering
User Name
Password
lost password?   |   register now

Reply
 
LinkBack Thread Tools
  #1 (permalink)  
Old 10-22-2004, 02:49 PM
coolstude's Avatar
Registered User
 
Last photo:
Join Date: Oct 2004
Location: oklahoma
Age: 44
Posts: 6
Wiki Edits: 0

Thanks: 0
Thanked 0 Times in 0 Posts
brake lockup

i need help . my brakes are bled , everything is in proper order , but my front brakes lockup after about 2 or 3 blocks driving . the pedal is fine , not too soft or too hard , master cylinder is a year old and has been bench bled , the booster is about 5 years old . worked just fine , but if i press the brakes several times , the fronts lock , but if i remove the vacuum to the booster , the brakes release , i'm a little confused , PLEASE HELP!!!!!!!!

    Advertisement
Reply With Quote Quick reply to this message
Sponsored Links
Advertisement
 
  #2 (permalink)  
Old 10-22-2004, 09:34 PM
dmc12mk3's Avatar
Member
 

Last journal entry: Fixed some leaks
Last photo:
Join Date: Aug 2003
Location: Chapin
Age: 34
Posts: 238
Wiki Edits: 0

Thanks: 0
Thanked 0 Times in 0 Posts
My first suspicion would be the pushrod that goes from your brake pedal to the brake cylinder. Make sure it is seated in its dimple and hasn't dropped down around the lip of the piston. Also make sure that you don't have the pushrod adjusted out too far and its allowing the vaccum from the engine to build up behind the diaphragm in the booster.
Reply With Quote Quick reply to this message
  #3 (permalink)  
Old 10-22-2004, 10:20 PM
coolstude's Avatar
Registered User
 
Last photo:
Join Date: Oct 2004
Location: oklahoma
Age: 44
Posts: 6
Wiki Edits: 0

Thanks: 0
Thanked 0 Times in 0 Posts
okay , sounds good , i will try anything at this point , it just has me baffled , it just started it out of nowhere and just about threw me off the highway one night , thanks a million , mike
Reply With Quote Quick reply to this message
  #4 (permalink)  
Old 10-23-2004, 07:54 AM
Tazz
 
Last photo:
Join Date: Jun 2001
Location: amherst,ohio
Age: 66
Posts: 2,049
Wiki Edits: 0

Thanks: 0
Thanked 0 Times in 0 Posts
You there is a brake pedal adjuster on the rod which you may have extended to far into the mastercylinder and causing the brakes to do this...back off the adjustment and start again. adjusting the rod to just hit the cup in the mastercylinder without pushing into it.



Tazz


Rat Rods Rule!
Reply With Quote Quick reply to this message
  #5 (permalink)  
Old 10-23-2004, 10:25 AM
coolstude's Avatar
Registered User
 
Last photo:
Join Date: Oct 2004
Location: oklahoma
Age: 44
Posts: 6
Wiki Edits: 0

Thanks: 0
Thanked 0 Times in 0 Posts
okay , i'll check it out , i've driven the stude with this setup for a while , even made a 1600 mile trip , never a problem , then suddenly , that's why i agree with you guys , seems like all is okay , but the padal or rod has to have gotten misalighned somewhere . anyway , thanks buddy and cool rides you have by the way , mike
Reply With Quote Quick reply to this message
  #6 (permalink)  
Old 10-27-2004, 08:56 AM
coolstude's Avatar
Registered User
 
Last photo:
Join Date: Oct 2004
Location: oklahoma
Age: 44
Posts: 6
Wiki Edits: 0

Thanks: 0
Thanked 0 Times in 0 Posts
well , i tried all of the above , none of it has worked , it has gotten better , but still not perfect, so i think i'm gonna change out the booster and master cuz it almost seems as maybe over a period of time they have gotten worn and the plunger wont release all the time because it may be in a bind and when i let of vacuum the booster draws back . anyway , we'll see , thanks guys , mike
Reply With Quote Quick reply to this message

Recent Suspension - Brakes - Steering posts with photos

Quick Reply
Message:
Options

Register Now

In order to be able to post messages on the Hot Rod Forum : Hotrodders Bulletin Board forums, you must first register.
Please enter your desired user name (usually not your first and last name), your email address and other required details in the form below.
User Name:
If you do not want to register, fill this field only and the name will be used as user name for your post.
Password
Please enter a password for your user account. Note that passwords are case-sensitive.
Password:
Confirm Password:
Email Address
Please enter a valid email address for yourself.
Email Address:

Log-in

Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.




Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools

Posting Rules
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On



All times are GMT -6. The time now is 08:44 AM.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.
Search Engine Optimization by vBSEO 3.6.0 PL2
Copyright Hotrodders.com 1999 - 2012. All Rights Reserved.