Hot Rod Forum : Hotrodders Bulletin Board - View Single Post - Brake Pressure Issues,, Help Please
View Single Post
  #1 (permalink)  
Old 04-12-2010, 10:12 AM
obengston's Avatar
obengston obengston is offline
USMC
 
Last photo:
Join Date: Sep 2009
Location: Jacksonvills, NC
Age: 43
Posts: 167
Wiki Edits: 0

Thanks: 0
Thanked 0 Times in 0 Posts
Brake Pressure Issues,, Help Please

I have a 68 Camaro with the factory power disc/drum set-up. I just recently added a Moser rear end with disc brakes (SSBC brakes). I called SSBC and they said I should be able to use the set up I had. I have all new stainless brake lines front to rear, and new rubber flex lines in the front. The front is the factory 4 piston disc brakes. I have lost all pressure. I also changed the M/C with a new one (stock), but still can't build pressure. I bench bleed the M/C and started at the right rear trying to bleed, but can't seem to build pressure up. The pedal goes to the floor. I believe the proporting valve may be leaking. Could that be my issue? I have sent for a new one. The distribution block seems to be good (but I don't know if that can have anything to do with it. The distribution block is just below the M/C, and the proportiong block is to the right of that. If I pump the brake really fast after about a second pressure/air will push back up into the Master cylinder from the front part of it, which I believe is the part that runs to the proportioning block. I could be wrong on the name I'm calling it a proportioning block, but I have seen sites that list it as a hold off valve (may be the same just worded different. Any suggestions????

Thanks
Reply With Quote