Brake problem?? - Hot Rod Forum : Hotrodders Bulletin Board
Hotrodders.com -- Hot Rod Forum



Register FAQ Search Today's Posts Unanswered Posts Auto Escrow Insurance Auto Loans
Hot Rod Forum : Hotrodders Bulletin Board > Tech Help> Suspension - Brakes - Steering
User Name
Password
lost password?   |   register now

Reply
 
LinkBack Thread Tools
  #1 (permalink)  
Old 05-14-2006, 09:03 AM
Member
 
Join Date: Jan 2003
Location: Wilmington, MA
Posts: 40
Wiki Edits: 0

Thanks: 0
Thanked 0 Times in 0 Posts
Brake problem??

I replaced all the brakes in my wife's Escort about a month ago. Ever since there's been a loud squeaking coming from the rear brakes at low speeds applying the brakes. The strangest part is it's only when they are cold . When they warm up, after a few miles, it goes away. Can someone shed some light on this problem?
Thanks,
John
Wilmington, MA

Last edited by cabrio; 05-14-2006 at 10:24 AM.
Reply With Quote Quick reply to this message
Sponsored Links
Advertisement
 
  #2 (permalink)  
Old 05-14-2006, 10:02 AM
xntrik's Avatar
Save a horse, Ride a Cowboy.
 
Last photo:
Join Date: Jul 2005
Location: Arkansas
Posts: 5,131
Wiki Edits: 0

Thanks: 0
Thanked 1 Time in 1 Post
Making the assumption that you did all the mechanical work correctly=====

My guess is it is the quality of the brake lining material.

I only buy Wagner products period. Wagner Thermoquiet pads and shoes if they are available.

Most brake pads/shoes on the market are junk. Cheap is not OK.
Reply With Quote Quick reply to this message
  #3 (permalink)  
Old 05-14-2006, 05:52 PM
Member
 
Join Date: Jan 2003
Location: Wilmington, MA
Posts: 40
Wiki Edits: 0

Thanks: 0
Thanked 0 Times in 0 Posts
Thanks, xntrik.
I guess I'll have to do them again with quality shoes this time.
Reply With Quote Quick reply to this message

Recent Suspension - Brakes - Steering posts with photos

Quick Reply
Message:
Options

Register Now

In order to be able to post messages on the Hot Rod Forum : Hotrodders Bulletin Board forums, you must first register.
Please enter your desired user name (usually not your first and last name), your email address and other required details in the form below.
User Name:
If you do not want to register, fill this field only and the name will be used as user name for your post.
Password
Please enter a password for your user account. Note that passwords are case-sensitive.
Password:
Confirm Password:
Email Address
Please enter a valid email address for yourself.
Email Address:

Log-in

Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.




Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools

Posting Rules
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On


Similar Threads
Thread Thread Starter Forum Replies Last Post
Brakes that don't brake KONADOK Suspension - Brakes - Steering 40 12-12-2005 06:51 PM
74 Corvette Brake Problem iniguy Suspension - Brakes - Steering 7 07-02-2005 04:46 PM
Wheel clunking and brake squeal skizot Suspension - Brakes - Steering 29 10-09-2004 06:17 AM
brake booster vacuum problem spankthru Engine 1 06-18-2003 07:57 PM
Dot 5 Silicone Brake Fluid?? Yes or No ?? Jim Weeks Suspension - Brakes - Steering 18 04-15-2002 06:22 AM


All times are GMT -6. The time now is 01:15 PM.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.
Search Engine Optimization by vBSEO 3.6.0 PL2
Copyright Hotrodders.com 1999 - 2012. All Rights Reserved.