Brake question - Hot Rod Forum : Hotrodders Bulletin Board
Hotrodders.com -- Hot Rod Forum



Register FAQ Search Today's Posts Unanswered Posts Auto Escrow Insurance Auto Loans
Hot Rod Forum : Hotrodders Bulletin Board > Tech Help> Suspension - Brakes - Steering
User Name
Password
lost password?   |   register now

Reply
 
LinkBack Thread Tools
  #1 (permalink)  
Old 06-20-2004, 11:15 AM
Mooshaker's Avatar
Registered User
 
Join Date: Jan 2003
Location: Central Illnois
Posts: 14
Wiki Edits: 0

Thanks: 0
Thanked 0 Times in 0 Posts
Brake question

I cannot get the brakes to work properly on my 34 ford.

Details

New car with all new parts
Corvette master cyl 1" bore (Bench Bled) mounted on firewall
4 Wheel Disc GM Calipers
2# Wilwood residual valves mounted within 3" of MC
Dot 5 (Silicone brake fluid)


If I pump the petal 8 or 9 times I get good brakes that are not spongy. Soon after letting off the brake petal, the pads on the left rear wheel are loose. I can move the inside pad with my fingers.

Could the problem be that the residual valve is defective? The valve appears to be installed correctly as the MC side is toward the Master cylinder.

Any ideas?

Ron

    Advertisement
Reply With Quote Quick reply to this message

Recent Suspension - Brakes - Steering posts with photos

Quick Reply
Message:
Options

Register Now

In order to be able to post messages on the Hot Rod Forum : Hotrodders Bulletin Board forums, you must first register.
Please enter your desired user name (usually not your first and last name), your email address and other required details in the form below.
User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.
Password:
Confirm Password:
Email Address
Please enter a valid email address for yourself.
Email Address:

Log-in

Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.




Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools

Posting Rules
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On



All times are GMT -6. The time now is 06:55 AM.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.
Search Engine Optimization by vBSEO 3.6.0 PL2
Copyright Hotrodders.com 1999 - 2012. All Rights Reserved.