butchlanham - Hot Rod Forum : Hotrodders Bulletin Board
Hotrodders.com -- Hot Rod Forum



Register FAQ Search Today's Posts Unanswered Posts Auto Escrow Insurance Auto Loans
Hot Rod Forum : Hotrodders Bulletin Board > Tech Help> Engine
User Name
Password
lost password?   |   register now

Reply
 
LinkBack Thread Tools
  #1 (permalink)  
Old 07-03-2010, 03:21 PM
Registered User
 
Join Date: May 2010
Location: st.louis missouri
Posts: 3
Wiki Edits: 0

Thanks: 0
Thanked 0 Times in 0 Posts
butchlanham

Hi all, This is my second attempt to get some basics on how to check timing of a 2.2 Celica GT. I recently changed the timing belt but might have been a tooth out. So I had to move the location of the distributor until it started. I drove it for three days and all seemed OK. However, it started to lose power and then wouldn,t start. The plugs were fouled with oil. So I replaced them with new Platinum ones, cleaned the throttle body and it started on the first try. When I put it in gear and took off, it fell on it,s face. "NO BALLS". Would someone offer some suggestions as to what,s going on, Please ? Thank You in advance.. Butch

    Advertisement
Reply With Quote Quick reply to this message
Sponsored Links
Advertisement
 
  #2 (permalink)  
Old 07-03-2010, 06:25 PM
cobalt327's Avatar
WFO
 
Last wiki edit: Intake manifold
Last journal entry: 1980 Malibu Wagon
Last photo:
Join Date: Mar 2009
Location: Atlanta
Age: 59
Posts: 5,037
Wiki Edits: 1616

Thanks: 128
Thanked 597 Times in 546 Posts
Quote:
Originally Posted by butch lanham
Hi all, This is my second attempt to get some basics on how to check timing of a 2.2 Celica GT. I recently changed the timing belt but might have been a tooth out. So I had to move the location of the distributor until it started. I drove it for three days and all seemed OK. However, it started to lose power and then wouldn,t start. The plugs were fouled with oil. So I replaced them with new Platinum ones, cleaned the throttle body and it started on the first try. When I put it in gear and took off, it fell on it,s face. "NO BALLS". Would someone offer some suggestions as to what,s going on, Please ? Thank You in advance.. Butch
If the cams are out of phase, just turning the distributor to compensate for the ignition timing isn't the cure. You need to have the cam phased correctly and the timing set correctly- both. The way it sounds, neither is correct.
Reply With Quote Quick reply to this message
  #3 (permalink)  
Old 07-03-2010, 08:52 PM
Registered User
 
Join Date: May 2010
Location: st.louis missouri
Posts: 3
Wiki Edits: 0

Thanks: 0
Thanked 0 Times in 0 Posts
butchlanham

Thanks for your quick response to my dilema. I inadvertantly found out why my 91 Celica GT, was losing power while in gear. It came to me like a bolt of lightning. You guessed it, the coil wire was arcing on the cold air intake tube. Man, I feel like an Idiot. I hope my painful experience can help someone with the same problem. Thank,s Again for your response. Later.
Reply With Quote Quick reply to this message

Recent Engine posts with photos

Quick Reply
Message:
Options

Register Now

In order to be able to post messages on the Hot Rod Forum : Hotrodders Bulletin Board forums, you must first register.
Please enter your desired user name (usually not your first and last name), your email address and other required details in the form below.
User Name:
If you do not want to register, fill this field only and the name will be used as user name for your post.
Password
Please enter a password for your user account. Note that passwords are case-sensitive.
Password:
Confirm Password:
Email Address
Please enter a valid email address for yourself.
Email Address:

Log-in

Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.




Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools

Posting Rules
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On



All times are GMT -6. The time now is 07:19 AM.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.
Search Engine Optimization by vBSEO 3.6.0 PL2
Copyright Hotrodders.com 1999 - 2012. All Rights Reserved.