Hot Rod Forum : Hotrodders Bulletin Board

Hot Rod Forum : Hotrodders Bulletin Board (http://www.hotrodders.com/forum/)
-   Transmission - Rearend (http://www.hotrodders.com/forum/transmission-rearend/)
-   -   C-6 shifting issues (http://www.hotrodders.com/forum/c-6-shifting-issues-232012.html)

junkyardjeff 04-19-2013 10:42 PM

C-6 shifting issues
 
I have a late 70s C-6 in my 66 F250 that sat for a few years before being installed in the 66,when I finally got the truck drivable I noticed it would not down shift into first at a light but it started to go into first now but is going from first to third and skipping second. It will manually shift fine so I am thinking that sitting for about 3 years without fluid and then 4 years while I got the body work done something is sticking,right now I am trying to get some carb/fuel delivery issues figured out I hope to put some miles on it to see if what ever is sticking will work loose. Its been so long since I took it out of the donor truck but thought it shifted like it should but I drove it home from buying it and then it sat.

Crosley 04-20-2013 07:29 AM

drive it a while. Check shift linkage adjustment

Make sure the vacuum source is hooked to direct manifold vacuum on intake, not spliced together with other hoses.

Make sure the TV linkage from carb down to the trans is operational and free moving

junkyardjeff 04-20-2013 06:37 PM

Took it for a drive today and I think its shifting very fast as I was able to feel all gears when taking off very slow.

joshp83 04-21-2013 10:27 AM

the servo is bad the piston gets hard replace it you should be fine


All times are GMT -6. The time now is 07:25 AM.

Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.
Search Engine Optimization by vBSEO 3.6.0 PL2
Copyright Hotrodders.com 1999 - 2012. All Rights Reserved.