Hot Rod Forum : Hotrodders Bulletin Board

Hot Rod Forum : Hotrodders Bulletin Board (http://www.hotrodders.com/forum/)
-   Electrical (http://www.hotrodders.com/forum/electrical/)
-   -   C10 fuel gauge issue (http://www.hotrodders.com/forum/c10-fuel-gauge-issue-223471.html)

ChadGresham 08-28-2012 07:14 PM

C10 fuel gauge issue
 
My fuel gauge recently quit working and now sits on 1/8th of a tank all the time. So i dropped the tank and replaced my sending unit and while i was at it replaced the rusted fuel tank straps, painted the brackets and undercoated my tank. While i had the sending unit unhooked the gauge went to full but now with my new sending unit in and 10 gallons of gas in the tank it still only reads 1/8th of a tank. Wiring is good so is it my gauge?

67Mustang Al. 08-29-2012 05:19 AM

1 Attachment(s)
With the float rising and falling in the tank it changes the resistance to the gauge. So when the float is high (full tank) there is low resistance and the gauge should show Full. You can test this with the sender out of the tank but you must ground the unit. Make sure your tank has a good ground.(use a second ground to check.) Normally the sender unit is matched with the gauge as a set or pair when new ,so if you have the correct replacement sender and you have made sure your gauge has a good ground connection ( add a second one to prove the ground connection from the gauge to battery negative.) the only thing left is a stuffed gauge.
Al.
the rusted fuel tank straps could have prevented a good earth as will painted metal. Clean metal gives a good earth.

ChadGresham 08-29-2012 06:57 AM

thanks for the diagram, it's alot simpler than my Haynes manual. So judging by the picture should i have some voltage reading going to the sending unit?

67Mustang Al. 08-29-2012 07:20 AM

Testing gauge and sender.
 
Fuel Gauge Unit Test
This should give you some food for thought. You should start by testing your gauge so this should help you out.
V=I times R
where v= volts, I= current and R= resistance. (sending unit varies from empty to full so voltage will also vary if you use this formula.
Al.

ChadGresham 08-29-2012 08:37 AM

At this point in time i do not have a working tester, only a test light. I have 12 volts to the gauge so should my test light pick up anything going to the sending unit? Right now when i unplug the sender the gauge goes to full and when i ground it out with the test light the gauge goes back to 1/8th of a tank...

67Mustang Al. 08-29-2012 05:43 PM

If you have replaced it already i am not sure what to suggest, you will have voltage across the gauge as the sender is a variable ground. Check your ground tank connection by getting your test light and find power from your battery with the clip of your test light and touch the sharp point of your tester on the tank..The varying voltage from the sending unit makes your gauge go up and down as your fuel level changes.
This is how you can check your sending wire for voltage ( i think you said you had light here with your probe)
Checking for incoming voltage to the sending unit..........
Clip the 12V test light to a good ground on your car. (clean metal) Then back probe the sending-unit power wire. If the light glows with a bright light, the unit is receiving power; otherwise, the power source is disconnected. (where you puncture your sending wire for checking you can put a drop of superglue on the puncture)
Al.

ChadGresham 08-29-2012 06:09 PM

Ah now we are getting somewhere! I checked today and i have no power through the wire, so i checked at several points on the wire in case there was a break in it. No power all the way up to the gauge, so at this point it must be the gauge right?

67Mustang Al. 08-29-2012 07:17 PM

AS the gauge is the only piece left to be checked and you have tested your grounds and continuity of the sending wire correctly, then it is most likely your gauge.
Al

ChadGresham 08-29-2012 08:07 PM

Well that's good and bad.. I guess I've narrowed down my problem, however fuel gauges are not cheap. Thanks for the help though! I tried "C10 forum"but those guys were no where near as nice as folks on this site

67Mustang Al. 08-29-2012 09:10 PM

Thats good then. Just check that when you get the replacement gauge it is compatible with the sending unit you bought. If the gauge is a direct replacement and not an after market x brand you should be good to go.:thumbup:
I am on my second oil pressure gauge (speco) and second tacho(speco) and travelled a thousand miles in total. Speco quality is better than my previous x brand which were made in a coal mine i would say.
Al.

ChadGresham 08-30-2012 06:08 AM

I'm going to stick with oe replacements for my truck although i did custom install a sunpro super tach II in the dash that is doing pretty good. Since we are on the topic of gauges and instruments, ever come across those Dakota digital setups? Those are nice

67Mustang Al. 08-30-2012 07:36 AM

No i have not seen Dakota brand here in Aus. Just Speco and a lot of chinese made gauges that give poor readings. Ebay , out of Hong Kong , have buckets of gauges for the unwary.:)
Al.

ChadGresham 08-30-2012 04:12 PM

Oh yeah you have to watch what you buy off Ebay! Bought some LED bulbs for my truck once that were junk!


All times are GMT -6. The time now is 04:20 AM.

Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.
Search Engine Optimization by vBSEO 3.6.0 PL2
Copyright Hotrodders.com 1999 - 2012. All Rights Reserved.