Hot Rod Forum : Hotrodders Bulletin Board

Hot Rod Forum : Hotrodders Bulletin Board (http://www.hotrodders.com/forum/)
-   Engine (http://www.hotrodders.com/forum/engine/)
-   -   c2500 oil pressure (http://www.hotrodders.com/forum/c2500-oil-pressure-146188.html)

kctransmec 10-06-2008 07:53 AM

c2500 oil pressure
 
I have A 1996 2500 chevy suburban with a 454 motor.
I was driveing up A steep grade when I Lost oil pressure and all power.
It will start but has no pressure and will shut off if put in gear.
The oil Level And Filter are fine. I have a C3500 Chevy with a 350 that is dooing the same thing. Help!!!

SlowGTA 10-06-2008 09:58 AM

What RPM is it idling at? If you give it throttle in park does the oil pressure come up?

Keep in mind that if you really have no oil flow you are damaging the engine by running it!

BTW, if you've had this happen to two trucks, remind me not to let you borrow mine :D

T-bucket23 10-06-2008 04:28 PM

What kind of filters are you using

Chet

GMC boogie 10-06-2008 04:34 PM

The oil pressure sensors on these trucks are known to go bad,give faulty readings,etc.

I would install a mechanical gauge just to verify oil pressure.

SSedan64 10-07-2008 01:29 AM

These have a safety feature. If the oil pressure drops below a certain psi. it cuts power to the fuel pump. May be bad oil pressure sending units like was mentioned above. Depending on what type sender you have N/O or N/C you may be able to just unplug the sender and see if it will run.

kctransmec 10-07-2008 08:37 AM

c2500 oil pressure
 
If you idle up the pressure goes up 2 or 3 PSI
I have been using Fram Filters

carsavvycook 10-07-2008 10:00 AM

Did both trucks start doing this at the same time, or say within a week, or so?

machine shop tom 10-07-2008 10:39 AM

Quote:

Originally Posted by kctransmec
If you idle up the pressure goes up 2 or 3 PSI
I have been using Fram Filters

Change the filters and see what happens.

Did this happen shortly after an oil/filter change?

Fram filters are known for causing pressure problems.

tom

TRAILERKING 10-07-2008 10:56 AM

Have an interesting comment to add. A DHL leased operator had a diesel cube van that he got towed into the GM dealer due to loss of oil pressure. They told him the motor will need to be tore down and inspected for trouble........big expense.
He ended up buying another cube van seeing his had a lot of miles on it. He sold his old one locally to a guy he new for $1,000.00.
A couple days later he gets a call from this guy and said the van runs fine............was just an oil pressure sending unit.
Nice diagnosis from the dealer.

kctransmec 10-10-2008 05:47 AM

c2500 oil pressure
 
The trucks messed up about 3 months apart.
I Changed the oil and unpluged the sending unit then started
the 3500. It ran ok, so I pluged it back in and it runs fine now.
Iplan to do the same to the 2500 next and see what it does.

ScoTFrenzel 10-11-2008 03:01 PM

Quote:

Originally Posted by TRAILERKING
Have an interesting comment to add. A DHL leased operator had a diesel cube van that he got towed into the GM dealer due to loss of oil pressure. They told him the motor will need to be tore down and inspected for trouble........big expense.
He ended up buying another cube van seeing his had a lot of miles on it. He sold his old one locally to a guy he new for $1,000.00.
A couple days later he gets a call from this guy and said the van runs fine............was just an oil pressure sending unit.
Nice diagnosis from the dealer.

I might be a bit cynical after all these years,
but,
IMO 80% of the shops are either incompetent or just plain THEIVES.

My $1200-1500 transmission overhaul estimate from 5 different shops finally only cost me $2 for a broken plastic bushing to fix it.
I bought that honest transmission man and his wife steak dinners for his free advice= and had to MAKE him take the money.
"A good man is worth his hire"

kctransmec 10-15-2008 05:42 AM

c2500 Oil Pressure
 
Well The c2500 worked when I unplugged the oil sensor
but I can not get the sensor out. Is there some trick
or special tool to remove it? I tried going from the bottom
and the from the top, I just cant get any tool on it.


All times are GMT -6. The time now is 04:52 AM.

Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.
Search Engine Optimization by vBSEO 3.6.0 PL2
Copyright Hotrodders.com 1999 - 2012. All Rights Reserved.