Hot Rod Forum : Hotrodders Bulletin Board - View Single Post - C5 output shaft loose
View Single Post
  #1 (permalink)  
Old 03-17-2004, 11:00 AM
k2mooch's Avatar
k2mooch k2mooch is offline
Member
 
Last photo:
Join Date: Sep 2003
Location: Fort Mill, SC
Age: 35
Posts: 174
Wiki Edits: 0

Thanks: 0
Thanked 0 Times in 0 Posts
C5 output shaft loose

After taking the C5 to a shop for a bench rebuild, they put a shift kit in and handed it back to me. I locked the converter into its splines, bolted it to the block, then converter bolts. Hooked everything else up snug and added 8 quarts very slowly (I heard adding it too quick causes an air pocket). After starting the car, I moved it through all the gears and then added about 3 more quarts till it read full, then shut it off to set a while.

When I started it back up and put it in drive to test, it engaged fine and I gave it a little gas. It felt like it was slipping going up the driveway, so after about 12 feet, I dropped it back to neutral and rolled it back down. I then put it back in drive to have no engagement at all. . . in any gear.

After removing the tranny, I noticed that the seals were still there in the front and rear, but the output shaft was loose. It had enough play in it that the splines would contact the housing.

Did I do something wrong on the install that would cause this, or was it assembled wrong? The guy is trying to figure out who's fault it was and that's what I told him happened pretty much word for word. Anybody have a similar problem with a rebuild?



MoocH
Reply With Quote