Hot Rod Forum : Hotrodders Bulletin Board

Hot Rod Forum : Hotrodders Bulletin Board (http://www.hotrodders.com/forum/)
-   Hotrodding Basics (http://www.hotrodders.com/forum/hotrodding-basics/)
-   -   cam bearing issues LS 6.0L blocks (http://www.hotrodders.com/forum/cam-bearing-issues-ls-6-0l-blocks-227572.html)

67-4-fun 12-25-2012 09:00 PM

cam bearing issues LS 6.0L blocks
 
for all you guys that are filimilar with the LS series engine. I was told today that there are cam bearing issues with the 6.0L blocks due to the oil sloshing around to much in the oil pump or something to that effect, causing cam bearing to go bad, anyone filmilare with the ls 6.0l blocks confirm this?

BOBCRMAN@aol.com 12-26-2012 09:56 AM

Only problems I have seen is a cracking problem with some casting numbers, never had a cam bearing problem.

mbossio 12-26-2012 11:37 AM

Haven't heard about that one but there are lots of oil pump issues, specifically with the preasure relief valve sticking open toasting the motor. You can read a lot about it on LS1GTO.com

67-4-fun 12-26-2012 01:31 PM

i was talking to my cousin yesturday during our family christmas, he knows a few mechanics working for local chevy dealers in indy, they told him they have had several 6.0L engines with cam bearing issuse, having cam bearing replace. I guess from talking to my cousin, the 6.0l must have oiling issuses to the cam bearings, causing cam bearing failure.. So that may go along with the what the previous post said about oil pumps.. im was just curious if it was a common problem with the 6.0L.. the 5.3L i guess dont have this issue.. but anyway you look at it a bad oil pump regardless will cause bearing failure


All times are GMT -6. The time now is 08:54 PM.

Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.
Search Engine Optimization by vBSEO 3.6.0 PL2
Copyright Hotrodders.com 1999 - 2012. All Rights Reserved.