car wont start timing help please - Hot Rod Forum : Hotrodders Bulletin Board
Hotrodders.com -- Hot Rod Forum



Register FAQ Search Today's Posts Unanswered Posts Auto Escrow Insurance Auto Loans
Hot Rod Forum : Hotrodders Bulletin Board > Tech Help> Engine
User Name
Password
lost password?   |   register now

Reply
 
LinkBack Thread Tools
  #1 (permalink)  
Old 10-20-2009, 06:00 PM
Registered User
 
Join Date: Aug 2009
Location: orange park fl
Posts: 24
Wiki Edits: 0

Thanks: 0
Thanked 0 Times in 0 Posts
car wont start timing help please

i have a chevy 355 vortec heads flat top pistons and holley 650 cfm carb i got every thing hooked up and when i try to start it the exust pops and the carb backfires but dosnt start and advise or idea would be great thank you if you need more info just ask

    Advertisement
Reply With Quote Quick reply to this message
Sponsored Links
Advertisement
 
  #2 (permalink)  
Old 10-20-2009, 06:24 PM
SSedan64's Avatar
Registered User
 
Last photo:
Join Date: Dec 2007
Location: Macon, GA.
Age: 50
Posts: 6,016
Wiki Edits: 0

Thanks: 0
Thanked 46 Times in 46 Posts
Timing Retarded or Distributor installed incorrectly>>>
http://www.chevytech.com/3c1.html
http://www.chevytech.com/2c44.html
Reply With Quote Quick reply to this message
  #3 (permalink)  
Old 10-20-2009, 06:31 PM
RSM's Avatar
RSM RSM is offline
Registered User
 
Join Date: Jun 2009
Location: Buckeye Az
Age: 52
Posts: 66
Wiki Edits: 0

Thanks: 0
Thanked 0 Times in 0 Posts
Sounds like your 180 degrees off on the dist. or you have some seriously tight valve adjustments. Check your timing and make sure the dist is in correctly.
Reply With Quote Quick reply to this message

Recent Engine posts with photos

Quick Reply
Message:
Options

Register Now

In order to be able to post messages on the Hot Rod Forum : Hotrodders Bulletin Board forums, you must first register.
Please enter your desired user name (usually not your first and last name), your email address and other required details in the form below.
User Name:
If you do not want to register, fill this field only and the name will be used as user name for your post.
Password
Please enter a password for your user account. Note that passwords are case-sensitive.
Password:
Confirm Password:
Email Address
Please enter a valid email address for yourself.
Email Address:

Log-in

Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.




Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools

Posting Rules
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On


Similar Threads
Thread Thread Starter Forum Replies Last Post
what is the fastest (factory) car you have ever driven? badknuckles Hotrodders' Lounge 320 12-09-2011 01:32 AM
Port or Full time vacuum cool rockin daddy Engine 129 10-05-2010 03:00 PM
car won't start please help SBC S-10 Engine 4 08-11-2005 08:42 PM
car well not start impala dreaming General Rodding Tech 6 02-22-2003 05:09 PM


All times are GMT -6. The time now is 03:32 AM.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.
Search Engine Optimization by vBSEO 3.6.0 PL2
Copyright Hotrodders.com 1999 - 2012. All Rights Reserved.