Hot Rod Forum : Hotrodders Bulletin Board - View Single Post - Car wont turn off with ignition
View Single Post
  #2 (permalink)  
Old 06-16-2012, 12:32 AM
ronbuhg's Avatar
ronbuhg ronbuhg is offline
Registered User
 
Join Date: May 2012
Posts: 35
Wiki Edits: 0

Thanks: 0
Thanked 2 Times in 2 Posts
Quote:
Originally Posted by dub
Ok......And yet again, I am on this great site asking for more help.
The car will start with the ignition as normal, but when I go to turn it off, the engine remains running. I have a HEI ignition, and I assume that the once power is killed to the cap/coil, the engine should turn off. Well, I have a wire going directly to the fuse panel under the dash, I tested the terminal that I plugged it into, it has switch power. But the engine doesnt turn of when I turn the ignition off. Which tells me that I have constant power at all times. Did I wire the engine bay wrong? I also tested the wire that goes to the alternator, and it has 12V at all times. Is that right? Does anyone have any ideas?

Thanks again,
Mike
When you turn it off , does the engine run on for a short time or stays running for awhile till you kill it ,however your doing that ?? If the electrical power is OFF when key is turned off, then I suggest you look at your idle speed. If its too high it will continue to run due to compression & fuel ,even with no electrics to spark it.. basically like the big tractor~trailers..hope thats it, but you need to fix it asap, because desiel run~on isnt good for the motor..let us know,,hey guys am I right or wrong here ??
Reply With Quote