Hot Rod Forum : Hotrodders Bulletin Board

Hot Rod Forum : Hotrodders Bulletin Board (http://www.hotrodders.com/forum/)
-   Engine (http://www.hotrodders.com/forum/engine/)
-   -   Carb Help Greatly Needed! (http://www.hotrodders.com/forum/carb-help-greatly-needed-53369.html)

my350camaro84 12-04-2004 04:36 PM

Carb Help Greatly Needed!
 
well. it's me again the good ol' 84 Camaro 305 H.O. guy. got a new problem for you today. Today I put a new Altenator in and now when I start the car it idles at 2000 and wont cut down when I hit the gas or even after it warms up. This car is carburated and has been sitting for ayear without being started up. I just recently put new plugs and wires on and started it just fine so within the past 2 months it's been started often. but before as i've mentioned it was just sitting for a good year or 2. I was just trying to get opinions on what you guys think is going on. I think that it's a stuck float but I'm not positive, I just want to get some input before I decide to rehaul this entire carb. thanks guys.

MI2600 12-04-2004 05:36 PM

It sounds like your carb linkage and/or the choke plate are sticking. Take the air cleaner off and make sure the choke is opening as it warms up. The choke has a fast idle cam that may have stuck.

my350camaro84 12-04-2004 06:27 PM

i don't know whats going on with it. it has a the linkage is fine but the actual piece doesn't fall back on the idle speed screw but when I click the choke it falls back on it and the idle slows till it stalls but the choke isn't even on when it's running because my choke light isn't on. I don't get it. i think I just may go buy a new Holley because this thing is pissing me off. it's still the stock 4-barrel chevy gives me.

stepside454 12-04-2004 06:36 PM

I dont know what the problem is with out seeing it...but it may be a simle fix for somebody who knows what there doing... & probably alot cheaper than going & buying a differant carb...+ your 84 uses a feedback carb...so if you put a Holley on it,you'll be messin with the computer & emissions. I wouldnt be to quick to dump the Qjet

rodnok1 12-05-2004 06:47 AM

Sounds lasike the throttle shaft is sticking open, I had a TA that would do that couple times a year. Spray some WD40, or a silicone spray lube on both sides at the throttle shaft. Might take a few shots, then work the throttle with engine off then hit it again. It was a Holley Carb.

DoubleVision 12-05-2004 07:02 AM

If you go to a squarebore holley you`ll need a adapter plate, if your still using the stock intake which will make matters worse.
Have you checked for vacuum leaks? have you checked the secondary`s to make sure there not partially stuck open? Q-jets are somewhat nortorious for this after they get some age on them. remove the air cleaner, open the top rear butterflies, shine a flashlight in the carbs throat and look at the lower butterflies, they may need lubed or possibly deburred.

my350camaro84 12-05-2004 07:18 PM

thanks for all the help guys I found out where it's sticking and I'm buying a new choke for it. the choke was the little bastard causing it all. thanks for the ideas though!


All times are GMT -6. The time now is 06:26 AM.

Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.
Search Engine Optimization by vBSEO 3.6.0 PL2
Copyright Hotrodders.com 1999 - 2012. All Rights Reserved.