Hot Rod Forum : Hotrodders Bulletin Board

Hot Rod Forum : Hotrodders Bulletin Board (http://www.hotrodders.com/forum/)
-   Engine (http://www.hotrodders.com/forum/engine/)
-   -   Carb question (http://www.hotrodders.com/forum/carb-question-68351.html)

chianesi 08-17-2005 05:16 PM

Carb question
 
I have a 78 silver ann. vette 350 w/ a Q-jet m#17059222. The engine will start and idle as long as I keep the choke almost completely closed. The moment I let go of the choke the engine immediatley stalls. I have to hold the choke closed in order for it to start even if the engine is at running temp. The carb is brand new and worked just fine, engine ran...9 mo. ago when it was last started.

Anybody got any ideas...

67 Deuce 4 Me 08-17-2005 05:19 PM

Sounds to me like its Starving for fuel. Or has a large vacuum leak.

tornado-tech 08-17-2005 05:42 PM

Definitely I agree. Try spraying carb cleaner around the carb and intake to see if the rpm picks up.

Jmark 08-17-2005 05:51 PM

If it sat for 9 months, the gas probably evaporated and left some reisidue in the bowl which may have clogged the jets. Metering rod piston may be stuck too. May be time to remove the carb and pull the lid and take a look if you don't find any large vacuum leaks first.

docvette 08-17-2005 10:57 PM

Carb
 
Doc here, :pimp:

Or varnished stuck floats...

Doc :pimp:

chianesi 08-18-2005 08:28 AM

Thanks guys, I'll get back...


All times are GMT -6. The time now is 05:18 AM.

Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.
Search Engine Optimization by vBSEO 3.6.0 PL2
Copyright Hotrodders.com 1999 - 2012. All Rights Reserved.