Carb Rebuild Gone Wrong?? - Hot Rod Forum : Hotrodders Bulletin Board
Hotrodders.com -- Hot Rod Forum



Register FAQ Search Today's Posts Unanswered Posts Auto Escrow Insurance Auto Loans
Hot Rod Forum : Hotrodders Bulletin Board > Tech Help> Engine
User Name
Password
lost password?   |   register now

Reply
 
LinkBack Thread Tools
  #1 (permalink)  
Old 06-23-2010, 04:03 PM
DeathRattle's Avatar
Some Punk Kid
 
Last photo:
Join Date: Oct 2006
Location: Michigan
Age: 28
Posts: 787
Wiki Edits: 0

Thanks: 0
Thanked 2 Times in 2 Posts
Carb Rebuild Gone Wrong??

Looking for a little guidance on this one, as i am pretty much run dry on ideas at the moment.
This all pertains to a Holley 670 Vacuum secondary
Tore it down and cleaned it and put all new gaskets on it cause it sat for a few years. The motor ran and everything before i tore it down last week and the accel pump worked like a charm.

After assembly I get nothing from the squirters shooting into each barrel?
The fuel bowl is filled and float is set spot on.
I took the fuel bowl off and plugged the accel pump hole with finger and gently try to depress lever..it holds just fine so i assume the diaphragm is still good right?
Put it all back on and still nothing from the squirters..what you guys think?

Thanks for reading and any replies on the issue.

    Advertisement
Reply With Quote Quick reply to this message
Sponsored Links
Advertisement
 
  #2 (permalink)  
Old 06-23-2010, 04:14 PM
ericnova72's Avatar
More for Less Racer
 
Join Date: Jan 2007
Location: S.W. Lower Michigan
Age: 47
Posts: 9,173
Wiki Edits: 0

Thanks: 26
Thanked 411 Times in 378 Posts
There are two check valves in the accelerator pump circuit.

One is a steel needle about .090" in diameter and 3/8" long, it gets dropped in the passage hole below the shooter with the point facing down.

The second is usually a rubber umbrella type seal(usually orange colored) in the bottom of the pump cavity on the fuel bowl. The tip on the umbrella seal is pushed through the center hole in the bowl cavity, make sure you trim off the excess straight portion(not the flared portion) that sticks up inside the bowl so it doesn't interfere with the float.

Are both checks in place and good?? The rubber check can look good but fail to work correctly, you should always replace it at any rebuild.
Reply With Quote Quick reply to this message
  #3 (permalink)  
Old 06-23-2010, 05:00 PM
DeathRattle's Avatar
Some Punk Kid
 
Last photo:
Join Date: Oct 2006
Location: Michigan
Age: 28
Posts: 787
Wiki Edits: 0

Thanks: 0
Thanked 2 Times in 2 Posts
Well it wasnt total rebuild..i did nothing with the bowl or accel pump..and it worked just before i cleaned up the main body
Reply With Quote Quick reply to this message
  #4 (permalink)  
Old 06-23-2010, 07:10 PM
ericnova72's Avatar
More for Less Racer
 
Join Date: Jan 2007
Location: S.W. Lower Michigan
Age: 47
Posts: 9,173
Wiki Edits: 0

Thanks: 26
Thanked 411 Times in 378 Posts
If you use the wrong main body to metering block gasket it can cover the transfer hole also, as can the wrong metering block to bowl gasket.

Just follow the passage through the carb, it is a real simple to follow circuit from the bowl to the shooter.

Some carb cleaners will curl the edge of the umbrella check in the accelerator pump cavity and cause it to not work properly.
Reply With Quote Quick reply to this message
  #5 (permalink)  
Old 06-23-2010, 07:30 PM
DeathRattle's Avatar
Some Punk Kid
 
Last photo:
Join Date: Oct 2006
Location: Michigan
Age: 28
Posts: 787
Wiki Edits: 0

Thanks: 0
Thanked 2 Times in 2 Posts
yeah i guess i gotta triple check to see if the passage is clear again..bowl to block is good forsure..ill check again tho
no carb cleaner touched the accel pump

Thanks for the responses..everything is gonna be considered here for sure, gonna be something to make me slap myself
Reply With Quote Quick reply to this message

Recent Engine posts with photos

Quick Reply
Message:
Options

Register Now

In order to be able to post messages on the Hot Rod Forum : Hotrodders Bulletin Board forums, you must first register.
Please enter your desired user name (usually not your first and last name), your email address and other required details in the form below.
User Name:
If you do not want to register, fill this field only and the name will be used as user name for your post.
Password
Please enter a password for your user account. Note that passwords are case-sensitive.
Password:
Confirm Password:
Email Address
Please enter a valid email address for yourself.
Email Address:

Log-in

Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.




Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools

Posting Rules
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On


Similar Threads
Thread Thread Starter Forum Replies Last Post
Quadrajet Carb??????? zbhover Engine 15 08-26-2010 08:57 AM
Lean problems with BG Speed Demon carb Sixtyninemercury Engine 29 04-16-2008 08:02 AM
Solex carb rebuild Kaefer'60 Engine 2 11-25-2004 05:53 AM
my first carb rebuild montea Engine 1 10-01-2004 07:49 PM
holley 600 carb rebuild TheViper Engine 2 09-16-2003 09:52 PM


All times are GMT -6. The time now is 11:38 AM.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.
Search Engine Optimization by vBSEO 3.6.0 PL2
Copyright Hotrodders.com 1999 - 2012. All Rights Reserved.