carb set up? - Hot Rod Forum : Hotrodders Bulletin Board
Hotrodders.com -- Hot Rod Forum



Register FAQ Search Today's Posts Unanswered Posts Auto Escrow Insurance Auto Loans
Hot Rod Forum : Hotrodders Bulletin Board > Tech Help> Hotrodding Basics
User Name
Password
lost password?   |   register now

Reply
 
LinkBack Thread Tools
  #1 (permalink)  
Old 06-14-2013, 11:30 PM
Registered User
 
Last photo:
Join Date: Feb 2013
Posts: 17
Wiki Edits: 0

Thanks: 0
Thanked 1 Time in 1 Post
carb set up?

So every time I drive my car, I need to adjust the carb. Even after driving for a while, I need to mess with it again.
Idle comes up, then goes back down. Runs fine, then rough.
Fuel level seems to be set right, in the middle of the sight.
SBC, low compression, mild cam, Performer intake, Summit racing 600 cfm carb.

I replaced the feedback quad that was on there, wrong carb anyway.

I'm not a carb guru by any means. I've rebuilt a few quads and Holleys. Never had this problem before though.

Maybe another problem with the motor or something else?
Checked for a blown head gasket with the block checker thingy that goes on the radiator. No problems. I've adjusted, (re-adjusted, and re-adjusted some more) the lifters. All are set at 1/4 turn from "0" lash.
Reply With Quote Quick reply to this message
Sponsored Links
Advertisement
 
  #2 (permalink)  
Old 06-15-2013, 04:23 AM
poncho62's Avatar
Out of the Loop Moderator
 
Last wiki edit: Streetbeasts links
Last journal entry: at car show
Last photo:
Join Date: Oct 2003
Location: Hanover, Ontario, Canada
Age: 61
Posts: 16,781
Wiki Edits: 5

Thanks: 19
Thanked 231 Times in 191 Posts
Have you checked for vacuum leaks?
__________________
Ontario Rodders
Reply With Quote Quick reply to this message
  #3 (permalink)  
Old 06-15-2013, 07:30 AM
Proud LOSER
 
Last photo:
Join Date: Mar 2008
Location: Ottawa
Posts: 1,589
Wiki Edits: 0

Thanks: 39
Thanked 213 Times in 181 Posts
Quote:
Originally Posted by Super70DeadSled View Post
So every time I drive my car, I need to adjust the carb. Even after driving for a while, I need to mess with it again.
Idle comes up, then goes back down. Runs fine, then rough.
Fuel level seems to be set right, in the middle of the sight.
SBC, low compression, mild cam, Performer intake, Summit racing 600 cfm carb.

I replaced the feedback quad that was on there, wrong carb anyway.

I'm not a carb guru by any means. I've rebuilt a few quads and Holleys. Never had this problem before though.

Maybe another problem with the motor or something else?
Checked for a blown head gasket with the block checker thingy that goes on the radiator. No problems. I've adjusted, (re-adjusted, and re-adjusted some more) the lifters. All are set at 1/4 turn from "0" lash.
I had the same symptoms on my 750, idle would change and it did weird sht after driving it and it got warm. I lowered the floats below the sights, had to give the car a good hard nudge to see any fuel come out. That's all it took and it was cured after.
Reply With Quote Quick reply to this message
  #4 (permalink)  
Old 06-15-2013, 07:32 AM
RWENUTS's Avatar
Registered User
 
Last photo:
Join Date: Nov 2011
Location: Nanaimo, BC, Canada
Age: 62
Posts: 1,662
Wiki Edits: 0

Thanks: 29
Thanked 165 Times in 158 Posts
Possibly distributor weights sticking.
Reply With Quote Quick reply to this message
  #5 (permalink)  
Old 06-17-2013, 12:20 AM
Registered User
 
Last photo:
Join Date: Feb 2013
Posts: 17
Wiki Edits: 0

Thanks: 0
Thanked 1 Time in 1 Post
New dist. but checked the advance weights anyway. They're smooth.

Didn't have a chance to drive it, but adjusted the floats and ran it for a while. Messed with the timing again, Now I believe that I'm at 8 or so BTDC at idle and max of about 38 or so. Couldn't check what RPM, cause I was alone. With the bowls set lower, it seemed to run much better. Can't wait to drive it!


Thanks all!
Reply With Quote Quick reply to this message

Recent Hotrodding Basics posts with photos

Quick Reply
Message:
Options

Register Now

In order to be able to post messages on the Hot Rod Forum : Hotrodders Bulletin Board forums, you must first register.
Please enter your desired user name (usually not your first and last name), your email address and other required details in the form below.
User Name:
If you do not want to register, fill this field only and the name will be used as user name for your post.
Password
Please enter a password for your user account. Note that passwords are case-sensitive.
Password:
Confirm Password:
Email Address
Please enter a valid email address for yourself.
Email Address:

Log-in

Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.




Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools

Posting Rules
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On


Similar Threads
Thread Thread Starter Forum Replies Last Post
Carb set up help. bygddy Engine 35 11-08-2012 07:37 AM
what carb for my set up dro21_polo Engine 6 08-07-2012 09:59 AM
How Do I Bulid A Two Carb Set Up buggmann Engine 7 08-03-2008 10:17 PM
3x2 carb set up popbreed Engine 3 09-12-2007 01:12 AM
What if I set up a carb on my rebuild... CamMan Engine 1 12-20-2003 07:55 PM


All times are GMT -6. The time now is 08:22 PM.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.
Search Engine Optimization by vBSEO 3.6.0 PL2
Copyright Hotrodders.com 1999 - 2012. All Rights Reserved.