Carburetors Problem - Hot Rod Forum : Hotrodders Bulletin Board
Hotrodders.com -- Hot Rod Forum



Register FAQ Search Today's Posts Unanswered Posts Auto Escrow Insurance Auto Loans
Hot Rod Forum : Hotrodders Bulletin Board > Tech Help> Hotrodding Basics
User Name
Password
lost password?   |   register now

Reply
 
LinkBack Thread Tools
  #1 (permalink)  
Old 05-12-2009, 10:39 AM
Registered User
 

Last journal entry: 1955 Chevy Convertible
Last photo:
Join Date: Nov 2008
Location: San Diego Calif.
Posts: 52
Wiki Edits: 0

Thanks: 0
Thanked 0 Times in 0 Posts
Carburetors Problem

Help, I just bought a carbureator kit #1477 to rebuild my Carter AFB #9627S and and the kit didn't come with a new accelerator pump. My old one was a little worn (I should have kept it) however I didn't try to fix. I want to buy a new accelerator pump and I don't have any idea of what one to by I can't match the one I have on any of the websites. I've bend working on the problem for last day. Any suggestions on what type to by I think I need the 1407 and 1406 type from edelbrook. At this point I need to walk away for a while. Nick
Reply With Quote Quick reply to this message
Sponsored Links
Advertisement
 
  #2 (permalink)  
Old 05-12-2009, 06:39 PM
fast68's Avatar
likes chevy trucks & boobies
 
Last photo:
Join Date: Oct 2005
Location: IL
Posts: 1,970
Wiki Edits: 0

Thanks: 0
Thanked 0 Times in 0 Posts
napa may be able to help

if not then call a place such as summit etc

was the pump known to be bad ?

i have reused many when going through q jet carbs in the past becuse for some reason the new one just wouldnt work but the original one did.

it is odd sometimes.

no explanation for it


theres an AFB accel pump on this page


and heres a page of interest:
http://www.carburetor.ca/carbs/tech/...AVS-index.html


good luck

Last edited by fast68; 05-12-2009 at 06:49 PM.
Reply With Quote Quick reply to this message
  #3 (permalink)  
Old 05-12-2009, 08:15 PM
Registered User
 

Last journal entry: 1955 Chevy Convertible
Last photo:
Join Date: Nov 2008
Location: San Diego Calif.
Posts: 52
Wiki Edits: 0

Thanks: 0
Thanked 0 Times in 0 Posts
Thanks alot Fast 68 for the info. That one web page for parts really helped alot. I bought a 1407 accelerator pump and put in the carb I'm pretty sure thats the one. Why I took that origainal leather one apart I don't know. Only paid 10.00 for the carb at the swapmeet. Maybe I can find another with a good pump if this one doesn't work. Thanks again.
Reply With Quote Quick reply to this message
  #4 (permalink)  
Old 05-13-2009, 09:00 AM
MI2600's Avatar
Member# 3287
 

Last journal entry: Vortec Heads
Last photo:
Join Date: Jul 2002
Location: N. Muskegon, MI
Posts: 2,632
Wiki Edits: 0

Thanks: 0
Thanked 0 Times in 0 Posts
I found several of the Carter/Edelbrock kits don't include the pump. Since then, I ask if it is included with the rest of the kit. If I remember correctly, the last kits I bought were from AutoZone or some other fast-food parts place and it was included.
Reply With Quote Quick reply to this message
  #5 (permalink)  
Old 05-13-2009, 09:16 AM
Registered User
 

Last journal entry: 1955 Chevy Convertible
Last photo:
Join Date: Nov 2008
Location: San Diego Calif.
Posts: 52
Wiki Edits: 0

Thanks: 0
Thanked 0 Times in 0 Posts
Thanks alot. Your right Auto Zone does sell the complete kit thanks for the reply. Nick
Reply With Quote Quick reply to this message

Recent Hotrodding Basics posts with photos

Quick Reply
Message:
Options

Register Now

In order to be able to post messages on the Hot Rod Forum : Hotrodders Bulletin Board forums, you must first register.
Please enter your desired user name (usually not your first and last name), your email address and other required details in the form below.
User Name:
If you do not want to register, fill this field only and the name will be used as user name for your post.
Password
Please enter a password for your user account. Note that passwords are case-sensitive.
Password:
Confirm Password:
Email Address
Please enter a valid email address for yourself.
Email Address:

Log-in

Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.




Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools

Posting Rules
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On


Similar Threads
Thread Thread Starter Forum Replies Last Post
small blcok chevy! The ultimate starter problem! S.O.S. sugar ray Engine 12 07-19-2007 08:07 PM
I'm having a primer adhesion problem on one door Ripped Body - Exterior 10 06-08-2007 12:45 PM
96 Plymouth Voyager spark problem? baddbob Electrical 12 05-19-2007 03:44 PM
Qjet Choke problem 85chevtrk Engine 2 02-13-2005 09:44 PM
Q J Choke problem 85chevtrk Engine 2 02-13-2005 06:08 AM


All times are GMT -6. The time now is 09:21 AM.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.
Search Engine Optimization by vBSEO 3.6.0 PL2
Copyright Hotrodders.com 1999 - 2012. All Rights Reserved.