carter afb carb ? - Hot Rod Forum : Hotrodders Bulletin Board
Hotrodders.com -- Hot Rod Forum



Register FAQ Search Today's Posts Unanswered Posts Auto Escrow Insurance Auto Loans
Hot Rod Forum : Hotrodders Bulletin Board > Tech Help> Engine
User Name
Password
lost password?   |   register now

Reply
 
LinkBack Thread Tools
  #1 (permalink)  
Old 05-27-2010, 04:06 PM
Registered User
 
Last photo:
Join Date: Apr 2006
Location: N.j.
Age: 30
Posts: 64
Wiki Edits: 0

Thanks: 0
Thanked 0 Times in 0 Posts
carter afb carb ?

hi guys

i just got a gm performance crate engine and i hooked everything up and i put my old carter afb carb on it and its on a nascar ram air manifold my problem is that when i take off on the street it pops and then sometimes stales out but if i take off slowly with little throttle its works perfect its only when i give it full throttle from a dead stop.
dose any one have any ideas for me what it could be ?

thanks
dan

    Advertisement
Reply With Quote Quick reply to this message
Sponsored Links
Advertisement
 
  #2 (permalink)  
Old 05-27-2010, 04:51 PM
Registered User
 
Join Date: Dec 2008
Location: Antioch ca
Posts: 35
Wiki Edits: 0

Thanks: 0
Thanked 0 Times in 0 Posts
sounds like not enough or no accelerator pump. And also I would check to make sure the timing is right. look down into the carb with the motor not running and see if there is fuel squirting out when you hit the gas.
Reply With Quote Quick reply to this message
  #3 (permalink)  
Old 05-29-2010, 09:59 AM
Registered User
 
Last photo:
Join Date: Apr 2006
Location: N.j.
Age: 30
Posts: 64
Wiki Edits: 0

Thanks: 0
Thanked 0 Times in 0 Posts
carter afb carb ?

hi checked and im geting 2 squrts comming out when i move the throttle linkage back and forth with out the moter running and i set the timeing to what the motor called for

any other ideas

thenk you
dan
Reply With Quote Quick reply to this message
  #4 (permalink)  
Old 05-29-2010, 10:09 AM
377tk's Avatar
Registered User
 
Join Date: Dec 2009
Location: stl
Posts: 38
Wiki Edits: 0

Thanks: 16
Thanked 0 Times in 0 Posts
afb issues

It could still be the accelerator pump is putting out but not a strong signal. It also could need to be re calibrated. I would put a $30 rebuild kit in it and start there then you will have a good foundation to start with. Then if it still does it buy a recalibration kit from edelbrock.
Reply With Quote Quick reply to this message
  #5 (permalink)  
Old 05-29-2010, 10:38 AM
Registered User
 
Join Date: Dec 2008
Location: Antioch ca
Posts: 35
Wiki Edits: 0

Thanks: 0
Thanked 0 Times in 0 Posts
could be a vacuum leak. but almost always it is a lack of accelerator squirt to cover the instant lean condition under instant full throttle. and also I've had car s that you had to step down on the gas not just slam it for best take off. also what is a nascar ram air manifold? If it is a single plane on a mild motor you will never get rid of the off idle bog, there is just to much hole to fill with out enough flow. It will run ok but you cant expect great off idle response.
Reply With Quote Quick reply to this message
  #6 (permalink)  
Old 06-04-2010, 03:46 PM
Registered User
 
Last photo:
Join Date: Apr 2006
Location: N.j.
Age: 30
Posts: 64
Wiki Edits: 0

Thanks: 0
Thanked 0 Times in 0 Posts
carter afb carb ?

a nascar edition rpm air gap manifold is nothing more then just a edelbock performer series & thunder series avs square -bore.
Reply With Quote Quick reply to this message
  #7 (permalink)  
Old 06-04-2010, 03:51 PM
Registered User
 
Last photo:
Join Date: Apr 2006
Location: N.j.
Age: 30
Posts: 64
Wiki Edits: 0

Thanks: 0
Thanked 0 Times in 0 Posts
carter afb carb ?

http://www.jegs.com/i/Edelbrock/350/75013/10002/-1
Reply With Quote Quick reply to this message
  #8 (permalink)  
Old 06-04-2010, 03:54 PM
Registered User
 
Last photo:
Join Date: Apr 2006
Location: N.j.
Age: 30
Posts: 64
Wiki Edits: 0

Thanks: 0
Thanked 0 Times in 0 Posts
carter afb carb ?

also i pulled a plug and keep in mind i put all new plugs in when i first started the engine . well any way it was black and had some wetness on it .
dose this mean i am running to rich ?
if not dose any 1 know what it could be ?

thenk you guys
dan
Reply With Quote Quick reply to this message
  #9 (permalink)  
Old 06-04-2010, 08:32 PM
1BAD80's Avatar
The Smell of Nitro in the morn
 
Last wiki edit: How to adjust valves Last photo:
Join Date: Jun 2001
Location: Mich
Posts: 2,423
Wiki Edits: 2

Thanks: 0
Thanked 3 Times in 2 Posts
Herre is a downloadable file on tuning a Carter,
http://www.carburetor.ca/pdf_manuals...BSelection.pdf

Carter Tech Info,
http://www.carburetor.ca/carbs/tech/index.html

SERVICE AND TROUBLESHOOTING TIPS
http://www.thecarburetorshop.com/Troubleshooting.htm

Exploded View of a Carter model AFB Carburetor
http://www.carburetorfactory.com/expvw04.html
__________________
Luv the smell of NITRO in the morning.

Last edited by 1BAD80; 06-04-2010 at 08:47 PM.
Reply With Quote Quick reply to this message
  #10 (permalink)  
Old 06-05-2010, 01:01 AM
Registered User
 
Join Date: Aug 2008
Location: LA
Posts: 76
Wiki Edits: 0

Thanks: 0
Thanked 0 Times in 0 Posts
Edelbrock PN 1475. Your accelerator pump nozzles are too small.
Reply With Quote Quick reply to this message
  #11 (permalink)  
Old 06-05-2010, 01:05 AM
Registered User
 
Join Date: Aug 2008
Location: LA
Posts: 76
Wiki Edits: 0

Thanks: 0
Thanked 0 Times in 0 Posts
You'll probably need a tuning kit too. Edelbrock
Reply With Quote Quick reply to this message
  #12 (permalink)  
Old 06-14-2010, 07:21 PM
thewrongshop@yahoo.com
 
Last photo:
Join Date: Oct 2004
Location: New Jersey
Age: 63
Posts: 206
Wiki Edits: 0

Thanks: 1
Thanked 0 Times in 0 Posts
Carb, Miss, And Runing Hot

THE CARB WORKED GREAT ON THE OTHER ENGINE AND THE PROBLEM
ISN'T THE ACCELERATOR PUMP IT'S THE LINKAGE THAT IS MISSING THAT GOES TO THE PUMP SHAFT . M.O. I WOULD PUT MONEY ON A HEAD GASKET SINCE IT MAY HAVE RAN OVER 230+ , THE PROBLEM IS NOT PLUGS OR A CARB , IT WAS THE WAY THINGS WERE PUT TOGETHER WITH TOO MANY HANDS IN THE POT .

HOPE YA DIDN'T PUFF A HEAD GASKET THERE DAN... I TOLD YOU IF YOU NEEDED A HAND TO CALL ME ...... I'LL BET IF YOU PRESSURE TEST THE COOLING SYSTEM YOU'LL SEE A RISE OVER 19+ LBS. BEFORE THE FAN TURNS ON AND THEN OFF & THE UPPER HOSE IS A HARD AS A pvc PIPE.
Reply With Quote Quick reply to this message

Recent Engine posts with photos

Quick Reply
Message:
Options

Register Now

In order to be able to post messages on the Hot Rod Forum : Hotrodders Bulletin Board forums, you must first register.
Please enter your desired user name (usually not your first and last name), your email address and other required details in the form below.
User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.
Password:
Confirm Password:
Email Address
Please enter a valid email address for yourself.
Email Address:

Log-in

Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.




Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools

Posting Rules
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On


Similar Threads
Thread Thread Starter Forum Replies Last Post
Edelbrock VS Carter AFB hollywood2k Engine 22 04-03-2012 06:20 AM
old carter AFB rods or jets? fast68 General Rodding Tech 6 10-18-2009 09:16 PM
Carter AFB WOT tuning 70bird Engine 4 08-20-2008 11:28 AM
Carter AFB Carb: Little Ball Bearing Fell Out Of Somewhere Can't Find It's Home Brawler Engine 7 06-12-2007 05:15 PM
carter AFB ... any tips? Fizz Engine 2 04-25-2004 03:06 PM


All times are GMT -6. The time now is 01:24 AM.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.
Search Engine Optimization by vBSEO 3.6.0 PL2
Copyright Hotrodders.com 1999 - 2012. All Rights Reserved.