Hot Rod Forum : Hotrodders Bulletin Board - View Single Post - Carter / Edelbrock fuel pump & carb problems
View Single Post
  #16 (permalink)  
Old 01-16-2012, 06:42 PM
Irelands child's Avatar
Irelands child Irelands child is offline
Registered User
 
Last wiki edit: Ford engine specifications Last photo:
Join Date: Jan 2005
Location: Upstate New York
Posts: 4,710
Wiki Edits: 8

Thanks: 12
Thanked 146 Times in 130 Posts
Quote:
Originally Posted by 67Mustang Al.
Hi Dave
At this point there has been no response from Edelbrock after 6 pics +email to Edelbrock@edelbrock.com. I dont think i will hold my breath on that one.
So its an early Ford in the previous pic. It got my attention when i saw the induction system also. Having a belt drive off the end tells the story. Early charger by the look of the casting.
Taxes here are also ever increasing as my working wife tells me. We have a similar tale here in our household Dave.
I recall guys her at the local Bearing Manufacturer travelled globally selling our product including trips to Cleveland and the Clevite Manufacturing facility. One of the guys who used to do that now sells real estate and sails his yacht.
But he doesnt have a classic Mustang.
P.S Going to be around 30 here today, not minus 30 as one may find in upstate NY.
Cheers
suthen AL.
Al - it's actually gotten to around 30 here as well -- but *F

Edelbrock may have been off today - national "holiday", Martin Luther King Day so many have taken it for an R&R.

More later - I have a pocket door in my house apart

Dave W
Reply With Quote