Chevy 350 Overheating Help! - Hot Rod Forum : Hotrodders Bulletin Board
Hotrodders.com -- Hot Rod Forum



Register FAQ Search Today's Posts Unanswered Posts Auto Escrow Insurance Auto Loans
Hot Rod Forum : Hotrodders Bulletin Board > Tech Help> Engine
User Name
Password
lost password?   |   register now

Reply
 
LinkBack Thread Tools
  #1 (permalink)  
Old 08-03-2012, 08:32 AM
Registered User
 
Join Date: Aug 2012
Posts: 1
Wiki Edits: 0

Thanks: 0
Thanked 0 Times in 0 Posts
Chevy 350 Overheating Help!

Hi all,

So yesterday I went to put air in my tires, and filled up my radiator fluid first. Well, I stupidly forgot to put the radiator cap back on, drove the car for maybe 8 - 10 mintutes before realizing, and made a huge mess in my engine compartment. I figured, no problem I would just refill the fluid and put the cap back on. Well now my car is overheating - very badly. I know it's can't be because of the fluid level as I re-topped it off, so I don't know what it could be.
It looked like smoke was coming out of the oil cap on my valve cover.

Did I, perhaps, mess up the thermostat? I have NO idea why it's overheating. Any help would be greatly appreciated.

Thanks,
Phill

    Advertisement
Reply With Quote Quick reply to this message
Sponsored Links
Advertisement
 
  #2 (permalink)  
Old 08-03-2012, 08:56 AM
bigdog7373's Avatar
Of course it's fast
 
Last photo:
Join Date: May 2010
Location: florida
Posts: 2,673
Wiki Edits: 0

Thanks: 13
Thanked 49 Times in 49 Posts
Lots o' air in there. Need to burp it.
Open the cap and squeez each hose like 10 times, refill, repeat. Fill the overflow tank. Then put the cap on and run it up to temperature. Turn it off. Top off the overflow tank.
Other guys may have different ways of removing all the air but my way works fine for me, never had a problem.
Reply With Quote Quick reply to this message
  #3 (permalink)  
Old 08-03-2012, 06:59 PM
Registered User
 
Last photo:
Join Date: Apr 2007
Location: Seattle, Wa
Posts: 6,834
Wiki Edits: 0

Thanks: 4
Thanked 454 Times in 389 Posts
Quote:
Originally Posted by prutkiewicz View Post
Hi all,

So yesterday I went to put air in my tires, and filled up my radiator fluid first. Well, I stupidly forgot to put the radiator cap back on, drove the car for maybe 8 - 10 mintutes before realizing, and made a huge mess in my engine compartment. I figured, no problem I would just refill the fluid and put the cap back on. Well now my car is overheating - very badly. I know it's can't be because of the fluid level as I re-topped it off, so I don't know what it could be.
It looked like smoke was coming out of the oil cap on my valve cover.

Did I, perhaps, mess up the thermostat? I have NO idea why it's overheating. Any help would be greatly appreciated.

Thanks,
Phill
You do need to take refilling slowly to insure there are no trapped bubbles. But the smoking from the oil filler could be a very bad sign. If you pushed the engine long enough and hot enough there could be a lot of internal damage.

The problem with lost coolant is that the temp sender depends upon passing coolant to read temperature. With the coolant blow out and nothing but hot air and steam in the engine's cooling passages the temp readings can be way behind events and under-reporting where the temps are really at. Add to that if you put coolant into the super heated interior, there are good chances that castings have cracked. When a major loss of coolant occurs the best thing to do is shut it off and leave it set for a couple hours before adding any coolant. Yes the thermostat could have been damaged by this incident.

I wish I could be more positive, but this level of overheating combined with and/or caused by the loss of coolant can be extremely damaging to an engine.

Bogie
Reply With Quote Quick reply to this message
  #4 (permalink)  
Old 08-04-2012, 01:01 AM
Registered User
 
Last photo:
Join Date: Mar 2009
Location: Burton, MI
Posts: 794
Wiki Edits: 0

Thanks: 38
Thanked 15 Times in 14 Posts
at 8 to 10 minutes, it's not likely any serious damage was done.. But w/o seeing the engine in person, I can't say with 100% certainty..

However, it does sound like you have a big air bubble in there.

Will you please explain how you have determined it is overheating badly? Smoke from the oil filler is "somewhat" normal especially if the engine has a lot of miles (it's not a good sign, but it's not the end of the world either)

What temps are you seeing that you call 'overheating badly'? Anything up to 230F is not a big deal. (I wouldn't recommend running an engine that hot, but it _shouldn't_ cause damage) are you seeing steam from the radiator cap?

make sure you hose the radiator down with lots of clean water while the engine is cold, then let it dry.. if you got antifreeze on it, it will create steam as the radiator gets hot and confuse you..

i have found sometimes when I have an engine that is being stubborn about burping the air out, that bringing the rev's up to about 3000 rpm and holding it there for a few seconds is often enough to get the water pump to push some water and move the air along.

however.. if you have to 'top off' your coolant on a regular basis, you have a leak somewhere, and should do your best to find it, and fix it.
Reply With Quote Quick reply to this message
  #5 (permalink)  
Old 08-04-2012, 01:14 AM
Registered User
 
Join Date: Aug 2012
Posts: 1
Wiki Edits: 0

Thanks: 0
Thanked 0 Times in 0 Posts
I think the TPI was a reverse cooled engine. The water pump turns backwards from an old school standard 350. I wonder if that is the issue. Google and call Arizona Speed and Marine. They are the tpi swap masters. I used thier stuff back in the day and they are very sharp on TPI engines.
Reply With Quote Quick reply to this message
  #6 (permalink)  
Old 08-04-2012, 06:35 AM
Registered User
 
Last photo:
Join Date: Mar 2009
Location: Burton, MI
Posts: 794
Wiki Edits: 0

Thanks: 38
Thanked 15 Times in 14 Posts
they aren't "reverse cooled" that's the LT-1 engine. they do use a 'reverse rotation' water pump, because the water pump is run off the back of the serpentine belt. These engines also require a reverse rotation fan if you use a belt driven fan.

LT1's pumped water to the heads first, then through the block which is why they were called 'reverse cooled'

but it is VERY easy to get the wrong water pump when it comes to reverse rotation...
Reply With Quote Quick reply to this message

Recent Engine posts with photos

Quick Reply
Message:
Options

Register Now

In order to be able to post messages on the Hot Rod Forum : Hotrodders Bulletin Board forums, you must first register.
Please enter your desired user name (usually not your first and last name), your email address and other required details in the form below.
User Name:
If you do not want to register, fill this field only and the name will be used as user name for your post.
Password
Please enter a password for your user account. Note that passwords are case-sensitive.
Password:
Confirm Password:
Email Address
Please enter a valid email address for yourself.
Email Address:

Log-in

Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.




Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools

Posting Rules
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On


Similar Threads
Thread Thread Starter Forum Replies Last Post
350 chevy overheating paul hodson Hotrodding Basics 3 11-30-2011 08:07 AM
Chevy 350 overheating coloradoinsane Engine 24 06-18-2010 09:30 PM
Chevy 350 long block overheating jeff79 Engine 92 08-28-2009 02:45 PM
350 chevy overheating & pinging Munchos90 Engine 6 01-09-2004 10:10 AM
chevy 350 overheating chevyelc81 Engine 8 07-04-2002 11:29 AM


All times are GMT -6. The time now is 11:09 PM.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.
Search Engine Optimization by vBSEO 3.6.0 PL2
Copyright Hotrodders.com 1999 - 2012. All Rights Reserved.