chevy electrical problem - Hot Rod Forum : Hotrodders Bulletin Board -- Hot Rod Forum

Register FAQ Search Today's Posts Unanswered Posts Auto Escrow Insurance Auto Loans
Hot Rod Forum : Hotrodders Bulletin Board > Tech Help> Electrical
User Name
lost password?   |   register now

LinkBack Thread Tools
  #1 (permalink)  
Old 02-14-2010, 02:29 PM
cutthroatkid's Avatar
two cups of tea
Last wiki edit: Need more horsepower for my 305 Last photo:
Join Date: Jun 2009
Location: st.louis mo
Posts: 1,046
Wiki Edits: 2

Thanks: 22
Thanked 3 Times in 3 Posts
chevy electrical problem

Ok so when I go to start my car theres a loud buzzin(the sam you hear if the headlights are on in park.)And the battery light on my dash comes on and wont go off.I had recently put on a tach and killswitch,well since this started,I took then off and put everyrhing the way it use to be(today)problem still occurs the car will evantually not wanna start.I put on a new battery new high torque starter and alternator same problem please help

Reply With Quote Quick reply to this message
Sponsored Links
  #2 (permalink)  
Old 02-20-2010, 09:50 AM
R4MM's Avatar
Join Date: Apr 2006
Location: eastern ireland
Age: 33
Posts: 33
Wiki Edits: 0

Thanks: 0
Thanked 0 Times in 0 Posts
ive had that b4 on 2 cars, they r sometimes electrical faults doesnt meen anything although anoying i found on 1 of them it was a sensory problem the sensor giving wrong signals to the electrics, if found it can be fixed easily unfortuatly it wasnt the case on the other car never found the reason on that one.
Reply With Quote Quick reply to this message
  #3 (permalink)  
Old 02-20-2010, 10:21 AM
hemi joe's Avatar
loves ex cop cars
Last photo:
Join Date: Apr 2009
Location: west deptford nj
Age: 54
Posts: 366
Wiki Edits: 0

Thanks: 0
Thanked 0 Times in 0 Posts
have you replaced battery cables?and check all of your ground connections.
Reply With Quote Quick reply to this message

Recent Electrical posts with photos
Gear in this thread - Powered by O'Reilly Auto Parts

Quick Reply

Register Now

In order to be able to post messages on the Hot Rod Forum : Hotrodders Bulletin Board forums, you must first register.
Please enter your desired user name (usually not your first and last name), your email address and other required details in the form below.
User Name:
Please enter a password for your user account. Note that passwords are case-sensitive.
Confirm Password:
Email Address
Please enter a valid email address for yourself.
Email Address:
Please select your insurance company (Optional)


Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.

Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
Thread Tools

Posting Rules
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

Similar Threads
Thread Thread Starter Forum Replies Last Post
fuel delivery problem with chevy 350 mb1d357 Engine 5 12-01-2008 10:40 PM
bb chevy cam problem? HELP joeyg329 Engine 16 10-02-2008 04:31 PM
57 Chevy Spring problem uskdab01 Suspension - Brakes - Steering 1 11-28-2007 08:59 PM
chevy 3 speed problem Niapym Transmission - Rearend 12 12-12-2004 11:54 PM
87 Chevy Pickup Timing Problem gs70ss Electrical 2 10-19-2003 12:04 PM

All times are GMT -6. The time now is 09:52 PM.

Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2015, vBulletin Solutions, Inc.
Search Engine Optimization by vBSEO 3.6.0 PL2
Copyright 1999 - 2012. All Rights Reserved.