Hot Rod Forum : Hotrodders Bulletin Board

Hot Rod Forum : Hotrodders Bulletin Board (http://www.hotrodders.com/forum/)
-   Engine (http://www.hotrodders.com/forum/engine/)
-   -   Chevy s10 Xtreme 4.3 V6?? (http://www.hotrodders.com/forum/chevy-s10-xtreme-4-3-v6-61947.html)

Mightymouse 04-27-2005 06:48 PM

Chevy s10 Xtreme 4.3 V6??
 
I just got the truck about 5 days agao its a 02 chevy s10 xtreme and my spark plug wire fell off it wuz running for about 10 mins before i knew it had fell off bcuz i was at work and i always let it warm up.. well i put it back on and theres still this bad smell coming from the exhast and the check engine soon lights still on but it runs fine what could it be??

advanced design 04-27-2005 07:16 PM

The unfiring cylinder has dumped unburned fuel into the catalytic converter causing the odor. The light is probably indicating a catalytic converter efficiency (or lack there of) problem.

Mightymouse 04-27-2005 08:05 PM

Will this fix itself and eventually go off? and should i disconnect the batterie so it resets the computer??

advanced design 04-27-2005 08:12 PM

I doubt it will fix itself. The constant on SES light indicates a current problem. If it was mine I would take it to the Chevy dealer to check out.

Siggy_Freud 04-27-2005 08:14 PM

Disconnecting the battery rarely will reset a code on an OBD2 type computer system. Go get the code scanned for free at autozone. Make sure your plug wire didn't burn or that other wires havent fallen off causing a constant misfire.

Mightymouse 04-27-2005 08:16 PM

Yea i was going to do that anyways.. I bought the extended warrenty so i guess that always comes in hand :D i was just curious.. But thanks


All times are GMT -6. The time now is 06:51 PM.

Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.
Search Engine Optimization by vBSEO 3.6.0 PL2
Copyright Hotrodders.com 1999 - 2012. All Rights Reserved.