CHROME PLUGS?? - Hot Rod Forum : Hotrodders Bulletin Board
Hotrodders.com -- Hot Rod Forum



Register FAQ Search Today's Posts Unanswered Posts Auto Escrow Insurance Auto Loans
Hot Rod Forum : Hotrodders Bulletin Board > Tech Help> Engine
User Name
Password
lost password?   |   register now

Reply
 
LinkBack Thread Tools
  #1 (permalink)  
Old 12-21-2001, 05:04 PM
Member
 
Last photo:
Join Date: Nov 2001
Location: Rutland Vermont
Age: 69
Posts: 137
Wiki Edits: 0

Thanks: 0
Thanked 0 Times in 0 Posts
Post CHROME PLUGS??

I JUST INSTALLED A NEW EDELBROCK INTAKE ON MY PROJECT 36 COUPE I'M IN THE PROCESS OF BUILDING AND THERE ARE TWO LARGE APPROX 1" HOLES IN THE FRONT OF THIS INTAKE. ONE IS FOR TEMP. SENSOR I'M GUESSINGTHE OTHER IS GOING TO GET PLUGED BUT WHEN I GO TO THE PARTS STORE THEY HAVE ONLY BRASS PLUDS AND THIS IS A CHROME HIGH POLISED INTAKE AND I DON'T WANT TO MESS IT UP WITH BRASS PLUGS. ANY IDEAS?

BOMO

    Advertisement
Reply With Quote Quick reply to this message
Sponsored Links
Advertisement
 
  #2 (permalink)  
Old 12-22-2001, 04:38 AM
Member
 
Join Date: Dec 2001
Location: East Palestine, Ohio
Posts: 150
Wiki Edits: 0

Thanks: 0
Thanked 0 Times in 0 Posts
Post

If you call a plumbing supply store you can get some stainles plugs that can be polished. Or you may able to get them in chrome plated brass as well. many standard pipe fitings can be had in chrome. Look around the next time you are in a public restroom

The last option is to buy the parts store units and have them plated.

Good Luck!
Reply With Quote Quick reply to this message
  #3 (permalink)  
Old 12-22-2001, 03:47 PM
Member
 
Last photo:
Join Date: Nov 2001
Location: Rutland Vermont
Age: 69
Posts: 137
Wiki Edits: 0

Thanks: 0
Thanked 0 Times in 0 Posts
Post

THANKS MUCH MIKE.

BOMO
Reply With Quote Quick reply to this message
  #4 (permalink)  
Old 12-28-2001, 04:48 PM
Registered User
 
Join Date: Dec 2001
Location: Montgomery, Texas
Posts: 8
Wiki Edits: 0

Thanks: 0
Thanked 0 Times in 0 Posts
Post

I used plugs that I bought from Summit to plug my Edelbrock holes. I think they had chrome ones also. Then actually removed one of them and added a fitting to hook my heater hose up to...forgot about heat!
Reply With Quote Quick reply to this message
  #5 (permalink)  
Old 01-01-2002, 11:29 AM
Member
 
Last photo:
Join Date: Nov 2001
Location: Rutland Vermont
Age: 69
Posts: 137
Wiki Edits: 0

Thanks: 0
Thanked 0 Times in 0 Posts
Post

CAPAN I DOUBT IN VT IF I'LL FORGET TO HOOK UP THE HEAT EVEN IN JUNE WE NEED IT HERE

THANKS

BOMO
Reply With Quote Quick reply to this message

Recent Engine posts with photos

Quick Reply
Message:
Options

Register Now

In order to be able to post messages on the Hot Rod Forum : Hotrodders Bulletin Board forums, you must first register.
Please enter your desired user name (usually not your first and last name), your email address and other required details in the form below.
User Name:
If you do not want to register, fill this field only and the name will be used as user name for your post.
Password
Please enter a password for your user account. Note that passwords are case-sensitive.
Password:
Confirm Password:
Email Address
Please enter a valid email address for yourself.
Email Address:

Log-in

Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.




Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools

Posting Rules
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On



All times are GMT -6. The time now is 11:03 PM.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.
Search Engine Optimization by vBSEO 3.6.0 PL2
Copyright Hotrodders.com 1999 - 2012. All Rights Reserved.