Clutch engagement at top of pedel - Hot Rod Forum : Hotrodders Bulletin Board
Hotrodders.com -- Hot Rod Forum



Register FAQ Search Today's Posts Unanswered Posts Auto Escrow Insurance Auto Loans
Hot Rod Forum : Hotrodders Bulletin Board > Tech Help> Transmission - Rearend
User Name
Password
lost password?   |   register now

Reply
 
LinkBack Thread Tools
  #1 (permalink)  
Old 04-23-2013, 06:09 PM
65ELCMO's Avatar
Registered User
 
Last photo:
Join Date: Dec 2009
Location: Tucson,AZ
Posts: 186
Wiki Edits: 0

Thanks: 2
Thanked 1 Time in 1 Post
Clutch engagement at top of pedel

Just put a new engine in a 65 El Camino. The car was not running when I got it. I used the clutch and throwout bearing that came out of it.
It had a Saganaw 4 speed in it and I chainged to a Muncie.
The clutch seems to work OK but I have 3 inches of pedel travel before engagement starts. It is just at the top of the pedel travel.
Any Ideas or is this just something I have to live with?

    Advertisement
Reply With Quote Quick reply to this message
Sponsored Links
Advertisement
 
  #2 (permalink)  
Old 04-23-2013, 07:02 PM
S10 Racer's Avatar
http://www.warsprints.com
 

Last journal entry: W.A.R. (Wingless Auto Racing) Sprint Car Racing
Last photo:
Join Date: Nov 2007
Location: At The Dirt Tracks
Age: 55
Posts: 1,888
Wiki Edits: 0

Thanks: 3
Thanked 62 Times in 56 Posts
Quote:
Originally Posted by 65ELCMO View Post
Just put a new engine in a 65 El Camino. The car was not running when I got it. I used the clutch and throwout bearing that came out of it.
It had a Saganaw 4 speed in it and I chainged to a Muncie.
The clutch seems to work OK but I have 3 inches of pedel travel before engagement starts. It is just at the top of the pedel travel.
Any Ideas or is this just something I have to live with?
I'm kind of confused with the pedal travel part. Just so you know, you should not have to depress the pedal to the floor to disengage the clutch and engagement should not be at the very top of the pedal travel. You should be able to feel when the throwout bearing starts to touch the pressure plate by the feel of the pedal, you should have about 1" of free pedal before that happens. This ensures that the throwout bearing is not turning all the time. It sounds like you just need to do some linkage adjustment.
Reply With Quote Quick reply to this message
  #3 (permalink)  
Old 04-24-2013, 06:00 PM
65ELCMO's Avatar
Registered User
 
Last photo:
Join Date: Dec 2009
Location: Tucson,AZ
Posts: 186
Wiki Edits: 0

Thanks: 2
Thanked 1 Time in 1 Post
I will check that. I just got the car out of storage. I moved and only drove it a few miles. Now I have it home to debug. Thanks
Reply With Quote Quick reply to this message

Recent Transmission - Rearend posts with photos

Quick Reply
Message:
Options

Register Now

In order to be able to post messages on the Hot Rod Forum : Hotrodders Bulletin Board forums, you must first register.
Please enter your desired user name (usually not your first and last name), your email address and other required details in the form below.
User Name:
If you do not want to register, fill this field only and the name will be used as user name for your post.
Password
Please enter a password for your user account. Note that passwords are case-sensitive.
Password:
Confirm Password:
Email Address
Please enter a valid email address for yourself.
Email Address:

Log-in

Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.




Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools

Posting Rules
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On


Similar Threads
Thread Thread Starter Forum Replies Last Post
98 s10 5spd hard to engage in gear, very early clutch engagement... 1986c10 Transmission - Rearend 4 01-31-2013 06:32 PM
cutting out when i let off or mid pedel rambler454 Engine 1 04-14-2012 08:46 PM
hard pedel slow stop campracing Suspension - Brakes - Steering 10 12-22-2009 08:09 AM
39 chev PU hanging pedel stea Suspension - Brakes - Steering 6 05-31-2005 11:12 AM
Brake pedel weak RickB1B Suspension - Brakes - Steering 21 02-12-2005 05:18 PM


All times are GMT -6. The time now is 05:24 AM.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.
Search Engine Optimization by vBSEO 3.6.0 PL2
Copyright Hotrodders.com 1999 - 2012. All Rights Reserved.