clutch problem - Hot Rod Forum : Hotrodders Bulletin Board
Hotrodders.com -- Hot Rod Forum



Register FAQ Search Today's Posts Unanswered Posts Auto Escrow Insurance Auto Loans
Hot Rod Forum : Hotrodders Bulletin Board > Tech Help> General Rodding Tech
User Name
Password
lost password?   |   register now

Reply
 
LinkBack Thread Tools
  #1 (permalink)  
Old 12-28-2011, 11:45 AM
Registered User
 
Join Date: Dec 2011
Posts: 1
Wiki Edits: 0

Thanks: 0
Thanked 0 Times in 0 Posts
clutch problem

i have a 95 Chevy k1500. i was installing a starter. my so got in and pushed in on the clutch pedal, now the pedal goes to the floor with no resistance.there is fluid in the reservoir.there was a load pop when it happened.the truck is back together now. any thoughts and be nice.

    Advertisement
Reply With Quote Quick reply to this message
Sponsored Links
Advertisement
 
  #2 (permalink)  
Old 12-28-2011, 07:07 PM
BOBCRMAN@aol.com's Avatar
Member
 
Last photo:
Join Date: May 2002
Location: Holly, michigan
Posts: 8,236
Wiki Edits: 0

Thanks: 30
Thanked 296 Times in 276 Posts
throwout arm/push rod came out.. or the slave has come apart..
Reply With Quote Quick reply to this message

Recent General Rodding Tech posts with photos

Quick Reply
Message:
Options

Register Now

In order to be able to post messages on the Hot Rod Forum : Hotrodders Bulletin Board forums, you must first register.
Please enter your desired user name (usually not your first and last name), your email address and other required details in the form below.
User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.
Password:
Confirm Password:
Email Address
Please enter a valid email address for yourself.
Email Address:

Log-in

Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.




Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools

Posting Rules
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On


Similar Threads
Thread Thread Starter Forum Replies Last Post
clutch problem 87fubar Transmission - Rearend 2 06-04-2011 02:30 AM
Hydraulic clutch problem 4811 Transmission - Rearend 8 01-22-2008 11:08 PM
htd clutch problem 2112jb Transmission - Rearend 2 02-16-2006 08:15 AM
CLutch problem deboner Introduce Yourself 1 10-21-2004 03:50 PM
'39 clutch problem Bills39Ford Transmission - Rearend 0 07-20-2002 10:37 AM


All times are GMT -6. The time now is 03:44 PM.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.
Search Engine Optimization by vBSEO 3.6.0 PL2
Copyright Hotrodders.com 1999 - 2012. All Rights Reserved.