Hot Rod Forum : Hotrodders Bulletin Board - View Single Post - comp cams XE cams
View Single Post
  #13 (permalink)  
Old 05-07-2009, 12:34 PM
Custom10's Avatar
Custom10 Custom10 is offline
my KARMA ran over my DOGMA
 

Last journal entry: SS
Last photo:
Join Date: May 2009
Location: Saskatchewan, Canada
Age: 50
Posts: 1,101
Wiki Edits: 0

Thanks: 18
Thanked 33 Times in 28 Posts
sent to my87z you in my other thread...

my87z I would say that the performance of my XE cam is very good, I have ran my fair share of SBC's in my day and this the first time with a comp XE. Other than the current noise issue I am happy with it. I guess its a matter of opinion, my engine builder friend does not like comp period because he has had some go flat on him right out of the gate and once that cast material is in the motor/oil/bearings its time for a complete tear down to clean it up which was at his cost. He said that comp cams are not parkerized which is a hardening process, also on there web site he mentioned that they were offering to parkerize the cams for an extra 100 bucks? I also talk with other local folks who swear by comp.

As mentioned by another..as with any cam, install it correctly matching up and checking other associated factors and break it in proper the XE should do you well. Personally I am still searching for any mistakes I made with mine that is causing the noise issue. So far I am chalking it up to the aggressive ramp rates used on the XE line. My big mystery is why it only makes the noise once the engine has warmed up? Other than that the performance is very very good.
Reply With Quote